ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/mysql.spec
Revision: 1.20
Committed: Fri Nov 2 19:48:17 2007 UTC (17 years, 5 months ago) by elmer
Branch: MAIN
CVS Tags: CMSSW_1_8_4, pe20080405-for184, CMSSW_1_8_3, pe20080326-for183, pe20080325-for183, CMSSW_1_8_2, pe20080324-for182, nr080320a, CMSSW_1_8_1, nr080314_181onl1, pe20080314-for181, CMSSW_1_8_0_ONLINE1, nr080310_180onl1, nr080307onl180onl1, CMSSW_1_8_0, pe20080304a-for180, pe20080303a-for18X, CMSSW_1_8_0_pre10, pe20080226-for180p10, pe20080220a-for18X, CMSSW_1_8_0_pre9, nr080215g491p01dbg, CMSSW_2_0_0_pre1, CMSSW_1_8_0_pre8, dl080202, pe20080126-for180p8, CMSSW_1_8_0_pre7, pe20080122a-for180p7, dl080120, pe20080120a-for180p7, pe20080117b-for180p7, pe20080117-for180p7, dl080115, CMSSW_1_8_0_pre6, NR080108_geant491-dbg-global, sm20080101a-newscram, pe20071127-ports, pe20071226c-for180p6, pe20071226b-for180p6, pe20071226a-for180p6, ge20071224, ge20071223, ge20071221, pe20071220b-for180p6, ge20071220, pe20071220-for180p6, ge20071217, CMSSW_1_8_0_pre5, pe20071216-for180p5, ge20071216, CMSSW_1_8_0_pre4-vg330, ge20071213, ge20071212-perfreport, ge20071212, ge20071211, ge20071210a, ge20071210, pe20071207-for180p4g491c3, NR071206_geant491cand3-global, ge20071207, pe20071206-for180test1, CMSSW_1_8_0_pre4-412, CMSSW_1_8_0_pre4, pe20071205b-for180p4-412, pe20071205b-for180p4, pe20071205-for180p4, ge20071205, CMSSW_1_8_0_pre3a-412, ge20071203, pe20071202-for180p3a-gcc412, CMSSW_1_8_0_pre3a, pe20071201b-for180p3a, pe20071201-for180p3a, V00-06-08, ge20071128, pe20071130-for180p3, pe20071129-for180p3, ge20071127a-leopard, ge20071127-leopard, pe20071127a-ports-412, ge20071126-new-bootstrap, CMSSW_1_8_0_pre2, CMSSW_1_8_0_pre0-amd64, CMSSW_1_8_0_pre0, pe20071123e-ports-412, pe20071123d-ports-412, pe20071123c-ports-422, pe20071123c-ports-412, pe20071123c-ports, pe20071123b-ports-422, pe20071123b-ports-412, pe20071123b-ports, pe20071123a-ports-422, pe20071123a-ports-412, pe20071123a-ports, ge20071122-new-bootstrap, pe20071121a-ports-422, pe20071121a-ports-412, pe20071121a-ports, pe20071112c-ports-422, pe20071112c-ports-412, pe20071112c-ports, pe20071112b-ports-412, pe20071112b-ports, pe20071112a-ports, pe20071105c-ports, pe20071105b-ports, pe20071105a-ports, pe20071103e-ports, pe20071103d-ports, pe20071103c-ports, pe20071103b-ports, pe20071103a-ports
Changes since 1.19: +1 -0 lines
Log Message:
Remove the mysql-test area from the rpm since it seems to be getting
obnoxiously large

File Contents

# User Rev Content
1 elmer 1.19 ### RPM external mysql 5.0.45-CMS18
2 eulisse 1.5 ## INITENV +PATH LD_LIBRARY_PATH %i/lib/mysql
3    
4 eulisse 1.3 #Different download locations according to the version.
5    
6 elmer 1.14 %if "%(echo %realversion | cut -d. -f1)" == "4"
7     %define source http://downloads.mysql.com/archives/mysql-4.0/%n-%realversion.tar.gz
8 eulisse 1.3 %else
9 muzaffar 1.17 %define source http://mirror.provenscaling.com/mysql/community/source/5.0/mysql-%realversion.tar.gz
10 eulisse 1.3 %endif
11    
12     Source: %source
13 eulisse 1.6 # Let's fake the fact that we have perl (DBI) so that rpm does not complain.
14     Provides: perl(DBI)
15 argiro 1.1
16     %prep
17 elmer 1.14 %setup -n %n-%realversion
18 argiro 1.1 %ifos darwin
19     # There's for some reason a "-traditional-cpp", which breaks with GCC 3.3
20     # so remove it. (FIXME: check if this is solved in a newer version.)
21     perl -p -i -e 's/-traditional-cpp/-no-cpp-precomp/g' configure.in configure
22     %endif
23    
24     %build
25     CFLAGS=-O3 CXX=gcc CXXFLAGS="-O3 -felide-constructors -fno-exceptions -fno-rtti" \
26     ./configure --prefix=%i --with-extra-charsets=complex \
27     --enable-thread-safe-client --enable-local-infile
28 eulisse 1.2 make %makeprocesses
29 muzaffar 1.17
30 eulisse 1.8 %install
31     make install
32 eulisse 1.11 perl -p -i -e "s|^#!.*perl(.*)|#!/usr/bin/env perl$1|" $(grep -r -e "^#!.*perl.*" %i | cut -d: -f1)
33 elmer 1.20 rm -fR %i/mysql-test
34 muzaffar 1.17
35     # SCRAM ToolBox toolfile
36     mkdir -p %i/etc/scram.d
37     cat << \EOF_TOOLFILE >%i/etc/scram.d/%n
38     <doc type=BuildSystem::ToolDoc version=1.0>
39     <Tool name=%n version=%v>
40     <Lib name=mysqlclient>
41     <Client>
42     <Environment name=MYSQL_BASE default="%i"></Environment>
43     <Environment name=LIBDIR default="$MYSQL_BASE/lib/mysql"></Environment>
44     <Environment name=MYSQL_BINDIR default="$MYSQL_BASE/bin"></Environment>
45     <Environment name=INCLUDE default="$MYSQL_BASE/include/mysql"></Environment>
46     </Client>
47     <Runtime name=PATH value="$MYSQL_BINDIR" type=path>
48     </Tool>
49     EOF_TOOLFILE
50    
51 eulisse 1.4 %post
52     %{relocateConfig}bin/msql2mysql
53     %{relocateConfig}bin/mysqlaccess
54     %{relocateConfig}bin/mysqlbug
55     %{relocateConfig}bin/mysql_config
56     %{relocateConfig}bin/mysqld_multi
57     %{relocateConfig}bin/mysqld_safe
58     %{relocateConfig}bin/mysql_fix_privilege_tables
59     %{relocateConfig}bin/mysql_install_db
60 muzaffar 1.17 %{relocateConfig}etc/scram.d/%n
61    
62 eulisse 1.4