ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/mysql.spec
Revision: 1.24
Committed: Fri Jun 5 17:10:45 2009 UTC (15 years, 10 months ago) by valya
Branch: MAIN
Changes since 1.23: +0 -1 lines
Log Message:
Move around MYSQL_HOME. It uses only in DBS when special MySQL config file used

File Contents

# User Rev Content
1 valya 1.23 ### RPM external mysql 5.1.35
2 eulisse 1.5 ## INITENV +PATH LD_LIBRARY_PATH %i/lib/mysql
3    
4 eulisse 1.3 #Different download locations according to the version.
5    
6 elmer 1.14 %if "%(echo %realversion | cut -d. -f1)" == "4"
7     %define source http://downloads.mysql.com/archives/mysql-4.0/%n-%realversion.tar.gz
8 eulisse 1.3 %else
9 valya 1.23 #%define source http://mirror.provenscaling.com/mysql/community/source/5.0/mysql-%realversion.tar.gz
10     %define source http://opensource.become.com/mysql/Downloads/MySQL-5.1/mysql-%realversion.tar.gz
11 eulisse 1.3 %endif
12    
13     Source: %source
14 eulisse 1.6 # Let's fake the fact that we have perl (DBI) so that rpm does not complain.
15     Provides: perl(DBI)
16 argiro 1.1
17     %prep
18 elmer 1.14 %setup -n %n-%realversion
19 argiro 1.1 %ifos darwin
20     # There's for some reason a "-traditional-cpp", which breaks with GCC 3.3
21     # so remove it. (FIXME: check if this is solved in a newer version.)
22     perl -p -i -e 's/-traditional-cpp/-no-cpp-precomp/g' configure.in configure
23     %endif
24    
25     %build
26     CFLAGS=-O3 CXX=gcc CXXFLAGS="-O3 -felide-constructors -fno-exceptions -fno-rtti" \
27     ./configure --prefix=%i --with-extra-charsets=complex \
28     --enable-thread-safe-client --enable-local-infile
29 eulisse 1.2 make %makeprocesses
30 muzaffar 1.17
31 eulisse 1.8 %install
32     make install
33 eulisse 1.11 perl -p -i -e "s|^#!.*perl(.*)|#!/usr/bin/env perl$1|" $(grep -r -e "^#!.*perl.*" %i | cut -d: -f1)
34 elmer 1.20 rm -fR %i/mysql-test
35 muzaffar 1.17
36     # SCRAM ToolBox toolfile
37     mkdir -p %i/etc/scram.d
38     cat << \EOF_TOOLFILE >%i/etc/scram.d/%n
39     <doc type=BuildSystem::ToolDoc version=1.0>
40     <Tool name=%n version=%v>
41     <Lib name=mysqlclient>
42     <Client>
43     <Environment name=MYSQL_BASE default="%i"></Environment>
44     <Environment name=LIBDIR default="$MYSQL_BASE/lib/mysql"></Environment>
45     <Environment name=MYSQL_BINDIR default="$MYSQL_BASE/bin"></Environment>
46     <Environment name=INCLUDE default="$MYSQL_BASE/include/mysql"></Environment>
47     </Client>
48     <Runtime name=PATH value="$MYSQL_BINDIR" type=path>
49     </Tool>
50     EOF_TOOLFILE
51    
52 eulisse 1.4 %post
53     %{relocateConfig}bin/msql2mysql
54     %{relocateConfig}bin/mysqlaccess
55     %{relocateConfig}bin/mysqlbug
56     %{relocateConfig}bin/mysql_config
57     %{relocateConfig}bin/mysqld_multi
58     %{relocateConfig}bin/mysqld_safe
59     %{relocateConfig}bin/mysql_fix_privilege_tables
60     %{relocateConfig}bin/mysql_install_db
61 muzaffar 1.17 %{relocateConfig}etc/scram.d/%n
62    
63 valya 1.23 # setup approripate links and made post install procedure
64     . $RPM_INSTALL_PREFIX/%{pkgrel}/etc/profile.d/init.sh
65     cat > $MYSQL_ROOT/etc/my.cnf << EOF
66     [mysqld]
67     max_allowed_packet=128M
68    
69     max_connections = 1000
70     connect_timeout = 60
71    
72     set-variable = innodb_log_file_size=512M
73     set-variable = innodb_log_buffer_size=8M
74     set-variable = innodb_buffer_pool_size=2G
75     set-variable = innodb_additional_mem_pool_size=50M
76    
77     key_buffer=512M
78    
79     query_cache_type=1
80     query_cache_limit=10M
81     query_cache_size=128M
82    
83     # inodb
84     innodb_thread_concurrency=0
85     innodb_concurrency_tickets=10000
86     innodb_commit_concurrency=0
87     innodb_flush_logs_at_trx_commit=0
88     innodb_flush_method=O_DIRECT
89     innodb_file_io_threads = 4
90     innodb_checksums=0
91     innodb_doublewrite=0
92    
93    
94     max_heap_table_size=1024M
95     tmp_table_size=1024M
96    
97     long_query_time=5
98     innodb_sync_spin_loops=60
99    
100     innodb_force_recovery = 0
101     innodb_lock_wait_timeout = 100
102     innodb_autoinc_lock_mode = 2
103    
104    
105     [mysql.server]
106     STRICT_TRANS_TABLES=1
107     transaction-isolation = READ-COMMITTED
108     EOF
109 eulisse 1.4