ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/mysql.spec
Revision: 1.25
Committed: Fri Jun 5 22:23:12 2009 UTC (15 years, 10 months ago) by valya
Branch: MAIN
CVS Tags: DBS-WEB_20090618, DBS-APPS_20090619, DBS-APPS_20090608, DBS-APPS_20090604_1
Changes since 1.24: +14 -15 lines
Log Message:
Fix issue with failed RPM build

File Contents

# User Rev Content
1 valya 1.23 ### RPM external mysql 5.1.35
2 eulisse 1.5 ## INITENV +PATH LD_LIBRARY_PATH %i/lib/mysql
3 valya 1.25 ## INITENV SET MYSQL_HOME $MYSQL_ROOT
4 eulisse 1.5
5 eulisse 1.3 #Different download locations according to the version.
6    
7 elmer 1.14 %if "%(echo %realversion | cut -d. -f1)" == "4"
8     %define source http://downloads.mysql.com/archives/mysql-4.0/%n-%realversion.tar.gz
9 eulisse 1.3 %else
10 valya 1.23 #%define source http://mirror.provenscaling.com/mysql/community/source/5.0/mysql-%realversion.tar.gz
11     %define source http://opensource.become.com/mysql/Downloads/MySQL-5.1/mysql-%realversion.tar.gz
12 eulisse 1.3 %endif
13    
14     Source: %source
15 eulisse 1.6 # Let's fake the fact that we have perl (DBI) so that rpm does not complain.
16     Provides: perl(DBI)
17 argiro 1.1
18     %prep
19 elmer 1.14 %setup -n %n-%realversion
20 argiro 1.1 %ifos darwin
21     # There's for some reason a "-traditional-cpp", which breaks with GCC 3.3
22     # so remove it. (FIXME: check if this is solved in a newer version.)
23     perl -p -i -e 's/-traditional-cpp/-no-cpp-precomp/g' configure.in configure
24     %endif
25    
26     %build
27     CFLAGS=-O3 CXX=gcc CXXFLAGS="-O3 -felide-constructors -fno-exceptions -fno-rtti" \
28     ./configure --prefix=%i --with-extra-charsets=complex \
29     --enable-thread-safe-client --enable-local-infile
30 eulisse 1.2 make %makeprocesses
31 muzaffar 1.17
32 eulisse 1.8 %install
33     make install
34 eulisse 1.11 perl -p -i -e "s|^#!.*perl(.*)|#!/usr/bin/env perl$1|" $(grep -r -e "^#!.*perl.*" %i | cut -d: -f1)
35 elmer 1.20 rm -fR %i/mysql-test
36 muzaffar 1.17
37     # SCRAM ToolBox toolfile
38     mkdir -p %i/etc/scram.d
39     cat << \EOF_TOOLFILE >%i/etc/scram.d/%n
40     <doc type=BuildSystem::ToolDoc version=1.0>
41     <Tool name=%n version=%v>
42     <Lib name=mysqlclient>
43     <Client>
44     <Environment name=MYSQL_BASE default="%i"></Environment>
45     <Environment name=LIBDIR default="$MYSQL_BASE/lib/mysql"></Environment>
46     <Environment name=MYSQL_BINDIR default="$MYSQL_BASE/bin"></Environment>
47     <Environment name=INCLUDE default="$MYSQL_BASE/include/mysql"></Environment>
48     </Client>
49     <Runtime name=PATH value="$MYSQL_BINDIR" type=path>
50     </Tool>
51     EOF_TOOLFILE
52    
53 valya 1.25 cat << \EOF > %i/etc/my.cnf
54 valya 1.23 [mysqld]
55     max_allowed_packet=128M
56    
57     max_connections = 1000
58     connect_timeout = 60
59    
60     set-variable = innodb_log_file_size=512M
61     set-variable = innodb_log_buffer_size=8M
62     set-variable = innodb_buffer_pool_size=2G
63     set-variable = innodb_additional_mem_pool_size=50M
64    
65     key_buffer=512M
66    
67     query_cache_type=1
68     query_cache_limit=10M
69     query_cache_size=128M
70    
71     innodb_thread_concurrency=0
72     innodb_concurrency_tickets=10000
73     innodb_commit_concurrency=0
74     innodb_flush_logs_at_trx_commit=0
75     innodb_flush_method=O_DIRECT
76     innodb_file_io_threads = 4
77     innodb_checksums=0
78     innodb_doublewrite=0
79    
80    
81     max_heap_table_size=1024M
82     tmp_table_size=1024M
83    
84     long_query_time=5
85     innodb_sync_spin_loops=60
86    
87     innodb_force_recovery = 0
88     innodb_lock_wait_timeout = 100
89     innodb_autoinc_lock_mode = 2
90    
91    
92     [mysql.server]
93     STRICT_TRANS_TABLES=1
94     transaction-isolation = READ-COMMITTED
95     EOF
96 eulisse 1.4
97 valya 1.25
98     %post
99     %{relocateConfig}bin/msql2mysql
100     %{relocateConfig}bin/mysqlaccess
101     %{relocateConfig}bin/mysqlbug
102     %{relocateConfig}bin/mysql_config
103     %{relocateConfig}bin/mysqld_multi
104     %{relocateConfig}bin/mysqld_safe
105     %{relocateConfig}bin/mysql_fix_privilege_tables
106     %{relocateConfig}bin/mysql_install_db
107     %{relocateConfig}etc/scram.d/%n
108