ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/mysql.spec
Revision: 1.3
Committed: Wed Apr 5 09:44:11 2006 UTC (19 years ago) by eulisse
Branch: MAIN
Changes since 1.2: +10 -3 lines
Log Message:
Updated to mysql5, as required by LCG_42a and some computing packages.

File Contents

# User Rev Content
1 eulisse 1.3 ### RPM external mysql 5.0.18
2     #Different download locations according to the version.
3    
4     %if "%(echo %v | cut -d. -f1)" == "4"
5     %define source http://downloads.mysql.com/archives/mysql-4.0/%n-%v.tar.gz
6     %else
7     %define source http://mysql.belnet.be/Downloads/MySQL-5.0/mysql-%v.tar.gz
8     %endif
9    
10     Source: %source
11 argiro 1.1
12     %prep
13     %setup -n %n-%v
14     %ifos darwin
15     # There's for some reason a "-traditional-cpp", which breaks with GCC 3.3
16     # so remove it. (FIXME: check if this is solved in a newer version.)
17     perl -p -i -e 's/-traditional-cpp/-no-cpp-precomp/g' configure.in configure
18     %endif
19    
20     %build
21     CFLAGS=-O3 CXX=gcc CXXFLAGS="-O3 -felide-constructors -fno-exceptions -fno-rtti" \
22     ./configure --prefix=%i --with-extra-charsets=complex \
23     --enable-thread-safe-client --enable-local-infile
24 eulisse 1.2 make %makeprocesses