ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/mysql.spec
Revision: 1.5
Committed: Tue Apr 18 16:18:37 2006 UTC (19 years ago) by eulisse
Branch: MAIN
CVS Tags: V00-00-00
Changes since 1.4: +2 -0 lines
Log Message:
mysql libs are in lib/mysql. Fixing LD_LIBRARY_PATH accordingly...

File Contents

# User Rev Content
1 eulisse 1.3 ### RPM external mysql 5.0.18
2 eulisse 1.5 ## INITENV +PATH LD_LIBRARY_PATH %i/lib/mysql
3    
4 eulisse 1.3 #Different download locations according to the version.
5    
6     %if "%(echo %v | cut -d. -f1)" == "4"
7     %define source http://downloads.mysql.com/archives/mysql-4.0/%n-%v.tar.gz
8     %else
9     %define source http://mysql.belnet.be/Downloads/MySQL-5.0/mysql-%v.tar.gz
10     %endif
11    
12     Source: %source
13 argiro 1.1
14     %prep
15     %setup -n %n-%v
16     %ifos darwin
17     # There's for some reason a "-traditional-cpp", which breaks with GCC 3.3
18     # so remove it. (FIXME: check if this is solved in a newer version.)
19     perl -p -i -e 's/-traditional-cpp/-no-cpp-precomp/g' configure.in configure
20     %endif
21    
22     %build
23     CFLAGS=-O3 CXX=gcc CXXFLAGS="-O3 -felide-constructors -fno-exceptions -fno-rtti" \
24     ./configure --prefix=%i --with-extra-charsets=complex \
25     --enable-thread-safe-client --enable-local-infile
26 eulisse 1.2 make %makeprocesses
27 eulisse 1.4 %post
28     %{relocateConfig}bin/msql2mysql
29     %{relocateConfig}bin/mysqlaccess
30     %{relocateConfig}bin/mysqlbug
31     %{relocateConfig}bin/mysql_config
32     %{relocateConfig}bin/mysqld_multi
33     %{relocateConfig}bin/mysqld_safe
34     %{relocateConfig}bin/mysql_fix_privilege_tables
35     %{relocateConfig}bin/mysql_install_db
36    
37