ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/mysql.spec
Revision: 1.6
Committed: Fri Apr 28 14:50:32 2006 UTC (19 years ago) by eulisse
Branch: MAIN
CVS Tags: V00-00-04, V00-00-03, V00-00-02, V00-00-01
Changes since 1.5: +3 -0 lines
Log Message:
Uses the system perl via the perl-virtual virtual package.

File Contents

# User Rev Content
1 eulisse 1.3 ### RPM external mysql 5.0.18
2 eulisse 1.5 ## INITENV +PATH LD_LIBRARY_PATH %i/lib/mysql
3    
4 eulisse 1.3 #Different download locations according to the version.
5    
6     %if "%(echo %v | cut -d. -f1)" == "4"
7     %define source http://downloads.mysql.com/archives/mysql-4.0/%n-%v.tar.gz
8     %else
9     %define source http://mysql.belnet.be/Downloads/MySQL-5.0/mysql-%v.tar.gz
10     %endif
11    
12     Source: %source
13 eulisse 1.6 Requires: perl-virtual
14     # Let's fake the fact that we have perl (DBI) so that rpm does not complain.
15     Provides: perl(DBI)
16 argiro 1.1
17     %prep
18     %setup -n %n-%v
19     %ifos darwin
20     # There's for some reason a "-traditional-cpp", which breaks with GCC 3.3
21     # so remove it. (FIXME: check if this is solved in a newer version.)
22     perl -p -i -e 's/-traditional-cpp/-no-cpp-precomp/g' configure.in configure
23     %endif
24    
25     %build
26     CFLAGS=-O3 CXX=gcc CXXFLAGS="-O3 -felide-constructors -fno-exceptions -fno-rtti" \
27     ./configure --prefix=%i --with-extra-charsets=complex \
28     --enable-thread-safe-client --enable-local-infile
29 eulisse 1.2 make %makeprocesses
30 eulisse 1.4 %post
31     %{relocateConfig}bin/msql2mysql
32     %{relocateConfig}bin/mysqlaccess
33     %{relocateConfig}bin/mysqlbug
34     %{relocateConfig}bin/mysql_config
35     %{relocateConfig}bin/mysqld_multi
36     %{relocateConfig}bin/mysqld_safe
37     %{relocateConfig}bin/mysql_fix_privilege_tables
38     %{relocateConfig}bin/mysql_install_db
39    
40