ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/mysqlpp.spec
Revision: 1.15
Committed: Tue May 13 17:29:46 2008 UTC (16 years, 11 months ago) by ratnik
Branch: MAIN
CVS Tags: MotT0_1_0_2, MotT0_1_0_1, MotT0_1_0_0, MotT0_100531_1, MotT0_100528_1, T0Mon_100518_1, T0Mon_100503_1, T0Mon_100316_1, T0Mon_100308_2, T0Mon_100308_1, T0Mon_100216_1, T0Mon_100210_1, T0Mon_100204_4, T0Mon_100204_3, T0Mon_100204_1, T0Mon_100127_1, T0Mon_091111_1, T0Mon_090828_1, T0Mon_090822_1, T0Mon_090715_1, T0Mon_090612_1, T0Mon_090611_1, T0Mon_090610_1, T0Mon_090601_1, T0Mon_090527_2, T0Mon_090527_1, T0Mon_090522_1, T0Mon_090519_2, T0Mon_090519_1, T0Mon_090517_1, T0Mon_090516_1, T0Mon_090515_4, T0Mon_090515_3, T0Mon_090515_2, T0Mon_090515_1, T0Mon_090510_1, T0Mon_090406_1, T0Mon_090326_1, T0Mon_090325_1, CMSSW_2_2_6_HLT_ONLINE1, nr090319_for226hltonl1, CMSSW_2_2_6_HLT_ONLINE, T0Mon_090318_1, T0Mon_090315_1, CMSSW_2_2_6_onlpatch1_ONLINE, CMSSW_2_2_6_ONLINE, nr090307for226_onlpatch1, nr090306onl226_tkonlsw_too_new, T0Mon_090303_1, T0Mon_081107_1, T0Mon_081105_1, PRODAGENT_0_12_2, CMSSW_2_1_9_ONLINE, T0Mon_080926_1, T0Mon_080920_2, T0Mon_080920_1, T0Mon_080916_2, T0Mon_080905_1, T0Mon_080905_01, T0Mon_080902_2, T0Mon_080902_1, T0Mon_080824_1, T0Mon_080823_1, CMSSW_2_1_4_ONLINE1, buildset_V2_8, CMSSW_2_1_1_ONLINE1, CMSSW_2_1_0_ONLINE1, nr080806_for210onl, CMSSW_2_0_10_ONLINE1, nr080714_forCRAB, nr080624_for21x, nr080623_for21x, CMSSW_2_0_8_ONLINE1-cms2, CMSSW_2_0_8_ONLINE1, SiteDB_030608_1, SiteDB_300508_1, nr080529_onl_cmsBuild, nr080528_onl_cmsBuild, SiteDB_280508_1
Changes since 1.14: +2 -2 lines
Log Message:
Changes for building online releases with cmsBuild:
 * Checking online_release flag is replaced by check if cmsplatf is
   "slc4onl_ia32_gcc346".

File Contents

# User Rev Content
1 elmer 1.14 ### RPM external mysqlpp 1.7.40-CMS19
2 eulisse 1.1 # Local patches and build system fudging by Lassi A. Tuura <lat@iki.fi>
3     # FIXME: zlib usage?
4 ratnik 1.11
5 ratnik 1.15 %if "%cmsplatf" != "slc4onl_ia32_gcc346"
6 eulisse 1.2 Requires: mysql zlib
7 ratnik 1.11 %endif
8    
9 eulisse 1.2 %define downloadn mysql++
10 elmer 1.8 Source: http://tangentsoft.net/%{downloadn}/releases/%{downloadn}-%realversion.tar.gz
11 elmer 1.4 Patch0: mysqlpp-macosx
12 eulisse 1.1
13     %prep
14 elmer 1.8 %setup -n %{downloadn}-%realversion
15 elmer 1.4 # The following is actually a gcc4 patch
16     %ifos darwin
17     %patch0 -p1
18     %endif
19 eulisse 1.1 rm -f config.status
20     [ $(uname) = Darwin ] && cp /usr/share/libtool/config.* .
21    
22     %build
23 ratnik 1.15 %if "%cmsplatf" != "slc4onl_ia32_gcc346"
24 eulisse 1.2 echo "ZLIB_ROOT" $ZLIB_ROOT
25     export CPPFLAGS=-I$ZLIB_ROOT/include
26     export LDFLAGS=-L$ZLIB_ROOT/lib
27 eulisse 1.1 ./configure --prefix=%i \
28 eulisse 1.2 --with-mysql=$MYSQL_ROOT \
29     --with-mysql-lib=$MYSQL_ROOT/lib/mysql \
30     --with-mysql-include=$MYSQL_ROOT/include/mysql
31 ratnik 1.11 %else
32     ./configure --prefix=%i
33     %endif
34 eulisse 1.1 perl -p -i -e 's/\@OBJEXT\@/o/g; s/\@EXEEXT\@//g' examples/Makefile
35     make
36 eulisse 1.5 #
37 muzaffar 1.10
38     %install
39     make install
40     # SCRAM ToolBox toolfile
41     mkdir -p %i/etc/scram.d
42     cat << \EOF_TOOLFILE >%i/etc/scram.d/%n
43     <doc type=BuildSystem::ToolDoc version=1.0>
44     <Tool name=MySQLpp version=%v>
45     <lib name=mysqlpp>
46     <Client>
47     <Environment name=MYSQLPP_BASE default="%i"></Environment>
48     <Environment name=LIBDIR default="$MYSQLPP_BASE/lib"></Environment>
49     <Environment name=INCLUDE default="$MYSQLPP_BASE/include"></Environment>
50     </Client>
51     <use name=mysql>
52     </Tool>
53     EOF_TOOLFILE
54    
55     %post
56     %{relocateConfig}etc/scram.d/%n