ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/mysqlpp.spec
Revision: 1.6
Committed: Wed Apr 18 23:46:01 2007 UTC (18 years ago) by ratnik
Branch: MAIN
CVS Tags: pe20070428a-ports, pe20070423b-ports, pe20070423a-ports
Changes since 1.5: +2 -0 lines
Log Message:
Changes for building  externals in 64/32 mode: added gcc-wrapper .

File Contents

# User Rev Content
1 eulisse 1.3 ### RPM external mysqlpp 1.7.40
2 ratnik 1.6 Requires: gcc-wrapper
3 eulisse 1.1 # Local patches and build system fudging by Lassi A. Tuura <lat@iki.fi>
4     # FIXME: zlib usage?
5 eulisse 1.2 Requires: mysql zlib
6     %define downloadn mysql++
7     Source: http://tangentsoft.net/%{downloadn}/releases/%{downloadn}-%v.tar.gz
8 elmer 1.4 Patch0: mysqlpp-macosx
9 eulisse 1.1
10     %prep
11 eulisse 1.2 %setup -n %{downloadn}-%v
12 elmer 1.4 # The following is actually a gcc4 patch
13     %ifos darwin
14     %patch0 -p1
15     %endif
16 eulisse 1.1 rm -f config.status
17     [ $(uname) = Darwin ] && cp /usr/share/libtool/config.* .
18    
19     %build
20 ratnik 1.6 ## IMPORT gcc-wrapper
21 eulisse 1.2 echo "ZLIB_ROOT" $ZLIB_ROOT
22     export CPPFLAGS=-I$ZLIB_ROOT/include
23     export LDFLAGS=-L$ZLIB_ROOT/lib
24 eulisse 1.1 ./configure --prefix=%i \
25 eulisse 1.2 --with-mysql=$MYSQL_ROOT \
26     --with-mysql-lib=$MYSQL_ROOT/lib/mysql \
27     --with-mysql-include=$MYSQL_ROOT/include/mysql
28 eulisse 1.1 perl -p -i -e 's/\@OBJEXT\@/o/g; s/\@EXEEXT\@//g' examples/Makefile
29     make
30 eulisse 1.5 #