ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/mysqlpp.spec
Revision: 1.8
Committed: Tue May 22 16:57:03 2007 UTC (17 years, 11 months ago) by elmer
Branch: MAIN
CVS Tags: ge20070629, pe20070626c-ports, ge20070625, pe20070626b-ports, sm20070626a-ports, pe20070626a-ports, pe20070625b-ports, pe20070625a-ports, pe20070624a-ports, ge20070622, pe20070607a-ports
Changes since 1.7: +3 -3 lines
Log Message:
o Updates to use %realversion from rpm-preamble
o Versions all updated to -XXXX (we can choose the actual rebuild naming
  convention in a second pass)

File Contents

# User Rev Content
1 elmer 1.8 ### RPM external mysqlpp 1.7.40-XXXX
2 eulisse 1.1 # Local patches and build system fudging by Lassi A. Tuura <lat@iki.fi>
3     # FIXME: zlib usage?
4 eulisse 1.2 Requires: mysql zlib
5     %define downloadn mysql++
6 elmer 1.8 Source: http://tangentsoft.net/%{downloadn}/releases/%{downloadn}-%realversion.tar.gz
7 elmer 1.4 Patch0: mysqlpp-macosx
8 eulisse 1.1
9     %prep
10 elmer 1.8 %setup -n %{downloadn}-%realversion
11 elmer 1.4 # The following is actually a gcc4 patch
12     %ifos darwin
13     %patch0 -p1
14     %endif
15 eulisse 1.1 rm -f config.status
16     [ $(uname) = Darwin ] && cp /usr/share/libtool/config.* .
17    
18     %build
19 eulisse 1.2 echo "ZLIB_ROOT" $ZLIB_ROOT
20     export CPPFLAGS=-I$ZLIB_ROOT/include
21     export LDFLAGS=-L$ZLIB_ROOT/lib
22 eulisse 1.1 ./configure --prefix=%i \
23 eulisse 1.2 --with-mysql=$MYSQL_ROOT \
24     --with-mysql-lib=$MYSQL_ROOT/lib/mysql \
25     --with-mysql-include=$MYSQL_ROOT/include/mysql
26 eulisse 1.1 perl -p -i -e 's/\@OBJEXT\@/o/g; s/\@EXEEXT\@//g' examples/Makefile
27     make
28 eulisse 1.5 #