ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/mysqlpp.spec
Revision: 1.10
Committed: Mon Sep 3 15:28:45 2007 UTC (17 years, 7 months ago) by muzaffar
Branch: MAIN
CVS Tags: CMSSW_1_7_7, dl080227for176, CMSSW_1_7_5, CMSSW_1_7_5_g491, dl080111, ge20080109-webconddb, ge20080109-sitedb, CMSSW_1_7_4, CMSSW_1_7_3_g490p1, dl071212t2, dl071212, CMSSW_1_7_3, CMSSW_1_7_2, CMSSW_1_7_1, nr071120_fwlite170_1, CMSSW_1_7_0, CMSSW_1_7_0_pre13, dl071114, ap20071113, CMSSW_1_7_0_pre12, CMSSW_1_7_0_pre11, pe20071102b-ports, pe20071102a-ports, CMSSW_1_7_0_pre10, CMSSW_1_7_0_pre9, CMSSW_1_7_0_pre8, CMSSW_1_7_0_pre7, dl071028, dl071024, nr071023_fwlite170p6, pe20071023-170p6-amd64, pe20071021-170p6-zlib, dl071021t2, dl071021, pe20071021a-ports, dl071020, CMSSW_1_7_0_pre6, pe20071015-xrootd, pe20071014-ports, dl071014, dl071010t2, dl071010, dl071009t2, dl071009, CMSSW_1_7_0_pre5, dl070926t2, dl070926, ap-20070926, CMSSW_1_7_0_pre4, dl070921t2, dl070921, dl070920, CMSSW_1_7_0_pre3, dl070916, dl070912, dl070812, sm070912b, sm070912a, sm070911a, dl070909p3, dl070909, CMSSW_1_7_0_pre2, dl070906, dl070905, sm030907a
Changes since 1.9: +21 -1 lines
Log Message:
new spec files for auto generation of toolfile i.e. no need of scramtoolbox

File Contents

# Content
1 ### RPM external mysqlpp 1.7.40-CMS8
2 # Local patches and build system fudging by Lassi A. Tuura <lat@iki.fi>
3 # FIXME: zlib usage?
4 Requires: mysql zlib
5 %define downloadn mysql++
6 Source: http://tangentsoft.net/%{downloadn}/releases/%{downloadn}-%realversion.tar.gz
7 Patch0: mysqlpp-macosx
8
9 %prep
10 %setup -n %{downloadn}-%realversion
11 # The following is actually a gcc4 patch
12 %ifos darwin
13 %patch0 -p1
14 %endif
15 rm -f config.status
16 [ $(uname) = Darwin ] && cp /usr/share/libtool/config.* .
17
18 %build
19 echo "ZLIB_ROOT" $ZLIB_ROOT
20 export CPPFLAGS=-I$ZLIB_ROOT/include
21 export LDFLAGS=-L$ZLIB_ROOT/lib
22 ./configure --prefix=%i \
23 --with-mysql=$MYSQL_ROOT \
24 --with-mysql-lib=$MYSQL_ROOT/lib/mysql \
25 --with-mysql-include=$MYSQL_ROOT/include/mysql
26 perl -p -i -e 's/\@OBJEXT\@/o/g; s/\@EXEEXT\@//g' examples/Makefile
27 make
28 #
29
30 %install
31 make install
32 # SCRAM ToolBox toolfile
33 mkdir -p %i/etc/scram.d
34 cat << \EOF_TOOLFILE >%i/etc/scram.d/%n
35 <doc type=BuildSystem::ToolDoc version=1.0>
36 <Tool name=MySQLpp version=%v>
37 <lib name=mysqlpp>
38 <Client>
39 <Environment name=MYSQLPP_BASE default="%i"></Environment>
40 <Environment name=LIBDIR default="$MYSQLPP_BASE/lib"></Environment>
41 <Environment name=INCLUDE default="$MYSQLPP_BASE/include"></Environment>
42 </Client>
43 <use name=mysql>
44 </Tool>
45 EOF_TOOLFILE
46
47 %post
48 %{relocateConfig}etc/scram.d/%n