ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/neon.spec
Revision: 1.1
Committed: Tue Jun 12 14:56:09 2007 UTC (17 years, 10 months ago) by eulisse
Branch: MAIN
Log Message:
* rpm now builds and works without any external dependency
* rpm updated to 4.4.9
* elfutils and neon added to the system (required by rpm)
* beecrypt and expat now work in a 64 bit environment

File Contents

# User Rev Content
1 eulisse 1.1 ### RPM external neon 0.26.3
2    
3     Source: http://www.webdav.org/%n/%n-%realversion.tar.gz
4     Requires: openssl expat zlib
5    
6     %build
7     export CPPFLAGS="-I$EXPAT_ROOT/include -I$ZLIB_ROOT/include -I$OPESSL_ROOT/include -I$EXPAT_ROOT/include"
8     export CFLAGS="-fPIC -g -O2"
9     export LDFLAGS="-L$EXPAT_ROOT/lib -L$ZLIB_ROOT/lib -L$OPENSSL_ROOT/lib"
10     ./configure --enable-shared --prefix=%i --with-pic --without-zlib --with-expat
11     make -j %makeprocesses
12     %post
13     %{relocateConfig}lib/libneon.la