1 |
ratnik |
1.1 |
### RPM external openldap 2.3.39
|
2 |
|
|
Source: ftp://ftp.openldap.org/pub/OpenLDAP/openldap-stable/openldap-stable-20071118.tgz
|
3 |
ratnik |
1.2 |
Requires: openssl db4
|
4 |
|
|
#cyrus-sasl
|
5 |
ratnik |
1.1 |
Provides: libsasl2.so.2
|
6 |
|
|
|
7 |
|
|
#http://www.openssl.org/source/%n-%realversion.tar.gz
|
8 |
|
|
|
9 |
|
|
%prep
|
10 |
|
|
%setup -q -n %n-%{realversion}
|
11 |
|
|
pwd
|
12 |
|
|
%build
|
13 |
|
|
|
14 |
ratnik |
1.2 |
pwd
|
15 |
|
|
|
16 |
|
|
# Fix missing sasl2 library link on 64-bit SLC4:
|
17 |
|
|
|
18 |
|
|
mkdir -p sasl2lib
|
19 |
|
|
ln -s /usr/lib/libsasl2.so.2.0.19 sasl2lib/libsasl2.so
|
20 |
|
|
|
21 |
ratnik |
1.1 |
# CC C compiler command
|
22 |
|
|
# CFLAGS C compiler flags
|
23 |
|
|
# LDFLAGS linker flags, e.g. -L<lib dir> if you have libraries in a
|
24 |
|
|
# nonstandard directory <lib dir>
|
25 |
|
|
# CPPFLAGS C/C++ preprocessor flags, e.g. -I<include dir> if you have
|
26 |
|
|
# headers in a nonstandard directory <include dir>
|
27 |
|
|
# CPP C preprocessor
|
28 |
|
|
|
29 |
ratnik |
1.2 |
export CPPFLAGS="-I$OPENSSL_ROOT/include -I$DB4_ROOT/include -I$CYRUS_SASL_ROOT/include"
|
30 |
|
|
export LDFLAGS="-L$OPENSSL_ROOT/lib -L$DB4_ROOT/lib -L$CYRUS_SASL_ROOT/lib -L%{_builddir}/%n-%{realversion}/sasl2lib"
|
31 |
|
|
echo $CPPFLAGS
|
32 |
|
|
which cc
|
33 |
|
|
which gcc
|
34 |
ratnik |
1.1 |
|
35 |
ratnik |
1.2 |
./configure --prefix=%i --with-cyrus-sasl --with-tls
|
36 |
ratnik |
1.1 |
make depend
|
37 |
|
|
make
|
38 |
|
|
%install
|
39 |
|
|
make install
|