ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/overview.spec
Revision: 1.17
Committed: Mon Mar 14 12:49:01 2011 UTC (14 years, 1 month ago) by lat
Branch: MAIN
CVS Tags: TW20110627a, TW20110623b, TW20110623a, HG1106e, builder_2011-06-17_14-52-14_cmsweb, builder_2011-06-16_19-08-24_wmagent, builder_2011-06-16_16-09-02_wmagent, builder_2011-06-15_16-54-18_wmagent, builder_2011-06-10_23-58-54_cmsweb, HG1106d, builder_2011-06-08_17-25-21_workqueue, builder_2011-06-07_22-07-15_reqmgr, builder_2011-06-04_17-45-11_dbs3, builder_2011-06-04_17-44-57_dbs3-client, builder_2011-05-31_01-23-03_cmsweb, builder_2011-05-31_00-51-28_cmsweb, HG1106c, TW20110530a, TW20110527b, TW20110527a, builder_2011-05-25_15-26-47_crab-server3, TW20110525a, TW20110524b, TW20110524a, builder_2011-05-24_10-10-21_cmsweb, HG1106b, builder_2011-05-23_17-26-34_crab-server3, builder_2011-05-20_10-32-01_sitereadiness, builder_2011-05-19_15-09-56_wmagent, builder_2011-05-16_15-13-08_cmsweb, HG1106a, builder_2011-05-13_17-08-55_wmagent, builder_2011-05-11_13-24-46_dbs3-client, builder_2011-05-09_14-05-53_dqmgui, builder_2011-05-05_16-10-12_py2-sqlobject, builder_2011-05-05_13-16-07_dqmgui, builder_2011-05-02_19-33-26_cmsweb, builder_2011-05-02_18-58-25_cmsweb, HG1105c, builder_2011-04-27_19-30-26_cmsweb, builder_2011-04-26_15-14-44_cmsweb, HG1105b, TW20110421b, TW20110421a, builder_2011-04-19_17-22-40_T0PromptSkim, TW20110419c, TW20110419b, TW20110419a, TW20110418a, builder_2011-04-16_00-43-59_reqmgr, TW20110415a, builder_2011-04-15_14-49-10_wmagent, TW20110414c, TW20110414b, TW20110414a, builder_2011-04-12_17-09-48_cmsweb, HG1105a, builder_2011-04-11_19-04-03_workqueue, builder_2011-04-08_17-08-57_cmsweb, HG1104e, builder_2011-04-08_12-05-32_calendar-shift, builder_2011-04-08_11-26-43_wmagent, ge20110407-igprof-book, builder_2011-04-07_19-51-01_calendar-shift, builder_2011-04-07_17-11-58_calendar-shift, builder_2011-04-07_16-23-25_calendar-shift, builder_2011-04-07_15-45-05_calendar-shift, TW20110407a, HG1104d, TW20110331c, TW20110331b, TW20110331a, TW20110330a, builder_2011-03-29_10-01-40_cmsweb, HG1104c, TW20110328a, builder_2011-03-25_15-38-34_cmsweb, builder_2011-03-25_12-48-58_cmsweb, builder_2011-03-24_17-23-46_reqmgr, builder_2011-03-23_16-16-18_cmsweb, builder_2011-03-23_16-04-32_cmsweb, builder_2011-03-23_11-32-11_cmsweb, builder_2011-03-23_10-48-54_cmsweb, HG1104b, builder_2011-03-23_09-32-23_cmsweb, TW20110322e, TW20110322d, TW20110322c, builder_2011-03-21_16-11-33_calendar-shift, builder_2011-03-21_16-08-10_calendar-shift, builder_2011-03-21_15-53-32_calendar-shift, builder_2011-03-18_17-21-58_cmsweb, HG1104a
Changes since 1.16: +2 -2 lines
Log Message:
DQM GUI, Overview 6.0.2, with --patch fixes.

File Contents

# User Rev Content
1 lat 1.17 ### RPM cms overview 6.0.2
2 lat 1.15 ## INITENV +PATH PYTHONPATH %i/lib/python`echo $PYTHON_VERSION | cut -d. -f 1,2`/site-packages
3 lat 1.17 ## INITENV +PATH PYTHONPATH %i/xlib/python`echo $PYTHON_VERSION | cut -d. -f 1,2`/site-packages
4 lat 1.1
5 lat 1.15 %define svn svn://svn.cern.ch/reps/CMSDMWM/Monitoring/tags/%{realversion}
6     Source: %{svn}?scheme=svn+ssh&strategy=export&module=Monitoring&output=/src.tar.gz
7     Requires: cherrypy py2-cheetah yui py2-cx-oracle py2-pil py2-matplotlib rotatelogs
8 lat 1.1
9     %prep
10 lat 1.15 # Unpack sources.
11     %setup -n Monitoring
12    
13     # Build
14 lat 1.1 %build
15 lat 1.15 python setup.py build_system -s Overview
16    
17     # Install
18     %install
19     mkdir -p %i/etc/profile.d %i/{x,}{bin,lib,include,data}
20     python setup.py install_system -s Overview --prefix=%i
21     find %i -name '*.egg-info' -exec rm {} \;
22    
23     # Generate dependencies-setup.{sh,csh} so init.{sh,csh} picks full environment.
24     : > %i/etc/profile.d/dependencies-setup.sh
25     : > %i/etc/profile.d/dependencies-setup.csh
26     for tool in $(echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'); do
27     root=$(echo $tool | tr a-z- A-Z_)_ROOT; eval r=\$$root
28     if [ X"$r" != X ] && [ -r "$r/etc/profile.d/init.sh" ]; then
29     echo "test X\$$root != X || . $r/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
30     echo "test X\$$root != X || source $r/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
31     fi
32 lat 1.1 done
33 lat 1.5
34 lat 1.15 # Generate an env.sh which sets a few things more than init.sh.
35     (echo ". %i/etc/profile.d/init.sh;"
36     echo "export PATH=%i/xbin:\$PATH;"
37 lat 1.5 echo "export LD_LIBRARY_PATH=%i/xlib:\$LD_LIBRARY_PATH;"
38     echo "export YUI_ROOT='$YUI_ROOT';"
39 lat 1.15 echo "export MONITOR_ROOT='%i';") > %i/etc/profile.d/env.sh
40 lat 1.1
41     %post
42 lat 1.15 %{relocateConfig}etc/profile.d/{env,dep*}.*sh