Revision: | 1.19 |
Committed: | Thu Jun 30 15:35:17 2011 UTC (13 years, 10 months ago) by lat |
Branch: | MAIN |
CVS Tags: | builder_2011-09-13_22-04-02_filemover, builder_2011-08-27_00-05-05_asyncstageout, builder_2011-08-26_19-05-27_crab-server3, builder_2011-08-12_22-56-45_cmsweb, builder_2011-08-09_17-03-37_dbs-server, builder_2011-08-09_14-45-47_dbs-client, builder_2011-08-08_23-23-23_dbs-server, DBS_2_1_6-pre5, DBS_2_1_6-pre4, TW20110808a, DBS_2_1_6-pre3, builder_2011-08-04_18-42-50_stagemanager-agent, builder_2011-08-04_17-25-36_das, builder_2011-08-04_13-25-47_cmsweb, builder_2011-08-02_16-19-02_wmagent, TW20110729a, builder_2011-07-28_21-25-51_dbs-server, builder_2011-07-28_21-25-43_dbs-client, DBS_2_1_6-pre2, TW20110728d, TW20110728c, TW20110728b, TW20110728a, builder_2011-07-28_00-46-23_cmsweb, DBS_2_1_6-pre1, builder_2011-07-27_18-04-14_reqmgr, HG1108a, builder_2011-07-20_14-45-50_wmagent, builder_2011-07-18_15-32-58_wmagent, builder_2011-07-14_18-33-29_asyncstageout, builder_2011-07-13_17-03-17_stagemanager-agent, builder_2011-07-13_16-55-50_stagemanager-agent, builder_2011-07-13_16-52-30_wmagent, builder_2011-07-11_12-04-16_cmsweb, builder_2011-07-11_11-53-31_cmsweb, HG1107c, HG1108a-osx, builder_2011-07-08_16-07-44_cmsweb, builder_2011-07-05_11-26-58_cmsweb, HG1107b, builder_2011-07-04_15-53-33_cmsweb, builder_2011-07-01_14-15-56_cmsweb, builder_2011-07-01_12-35-36_cmsweb |
Changes since 1.18: | +1 -1 lines |
Log Message: | Add py2-cjson dependency. |
# | User | Rev | Content |
---|---|---|---|
1 | lat | 1.17 | ### RPM cms overview 6.0.2 |
2 | lat | 1.18 | ## INITENV +PATH PATH %i/xbin |
3 | ## INITENV +PATH %{dynamic_path_var} %i/xlib | ||
4 | ## INITENV +PATH PYTHONPATH %i/$PYTHON_LIB_SITE_PACKAGES | ||
5 | ## INITENV +PATH PYTHONPATH %i/x$PYTHON_LIB_SITE_PACKAGES | ||
6 | lat | 1.1 | |
7 | lat | 1.15 | %define svn svn://svn.cern.ch/reps/CMSDMWM/Monitoring/tags/%{realversion} |
8 | Source: %{svn}?scheme=svn+ssh&strategy=export&module=Monitoring&output=/src.tar.gz | ||
9 | lat | 1.19 | Requires: cherrypy py2-cheetah yui py2-cx-oracle py2-pil py2-matplotlib py2-pycurl py2-cjson rotatelogs |
10 | lat | 1.1 | |
11 | %prep | ||
12 | lat | 1.15 | # Unpack sources. |
13 | %setup -n Monitoring | ||
14 | |||
15 | # Build | ||
16 | lat | 1.1 | %build |
17 | lat | 1.15 | python setup.py build_system -s Overview |
18 | |||
19 | # Install | ||
20 | %install | ||
21 | lat | 1.18 | mkdir -p %i/etc/profile.d %i/{x,}{bin,lib,include,data} %i/{x,}$PYTHON_LIB_SITE_PACKAGES |
22 | lat | 1.15 | python setup.py install_system -s Overview --prefix=%i |
23 | find %i -name '*.egg-info' -exec rm {} \; | ||
24 | |||
25 | # Generate dependencies-setup.{sh,csh} so init.{sh,csh} picks full environment. | ||
26 | : > %i/etc/profile.d/dependencies-setup.sh | ||
27 | : > %i/etc/profile.d/dependencies-setup.csh | ||
28 | for tool in $(echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'); do | ||
29 | root=$(echo $tool | tr a-z- A-Z_)_ROOT; eval r=\$$root | ||
30 | if [ X"$r" != X ] && [ -r "$r/etc/profile.d/init.sh" ]; then | ||
31 | echo "test X\$$root != X || . $r/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh | ||
32 | echo "test X\$$root != X || source $r/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh | ||
33 | fi | ||
34 | lat | 1.1 | done |
35 | lat | 1.5 | |
36 | lat | 1.15 | # Generate an env.sh which sets a few things more than init.sh. |
37 | (echo ". %i/etc/profile.d/init.sh;" | ||
38 | lat | 1.18 | echo "export YUI_ROOT;" |
39 | lat | 1.15 | echo "export MONITOR_ROOT='%i';") > %i/etc/profile.d/env.sh |
40 | lat | 1.1 | |
41 | %post | ||
42 | lat | 1.15 | %{relocateConfig}etc/profile.d/{env,dep*}.*sh |