ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/p5-dbd-oracle.spec
Revision: 1.36
Committed: Fri Oct 30 19:46:57 2009 UTC (15 years, 6 months ago) by elmer
Branch: MAIN
CVS Tags: pe20091108a-34X-slc4-gcc432, pe20091106a-34X-slc5-gcc434, pe20091106a-34X-slc4-gcc432, BUILDBOT_01, CERNOIDv02, pe20091103d-34X-slc5-gcc434, pe20091103d-34X-slc4-gcc432, pe20091103c-34X-slc5-gcc434, pe20091103c-34X-slc4-gcc432, pe20091103b-slc4-gcc432, pe20091103a-slc5-gcc434, pe20091103a-slc4-gcc432, pe20091103a--slc4-gcc432, pe20091103a-for34X, ge20091102-qt-conf, pe20091031a-for34X, pe20091030a-for34X
Changes since 1.35: +1 -1 lines
Log Message:
  Fix typo: "flase" -> "false" in case statement used to define whether it
  is in an online build on the basis of cmsplatf. (The definition should
  have been correct in any case, despite the typo, but correct the typo
  in any case.)

File Contents

# User Rev Content
1 andreasp 1.33 ### RPM external p5-dbd-oracle 1.17-CMS19
2 eulisse 1.9 ## INITENV +PATH PERL5LIB %i/lib/site_perl/%perlversion
3 andreasp 1.33 ## BUILDIF case $(uname):$(uname -p) in Linux:i*86 ) true ;; Linux:x86_64 ) true ;; Linux:ppc64 ) false ;; Darwin:* ) false ;; * ) false ;; esac
4     %define perlversion %(perl -e 'printf "%%vd", $^V')
5     %define perlarch %(perl -MConfig -e 'print $Config{archname}')
6 eulisse 1.1 %define downloadn DBD-Oracle
7 muzaffar 1.35 %define closingbrace )
8 elmer 1.36 %define online %(case %cmsplatf in *onl_*_*%closingbrace echo true;; *%closingbrace echo false;; esac)
9 ratnik 1.21
10 muzaffar 1.34 %if "%online" != "true"
11 ratnik 1.21 Requires: p5-dbi oracle
12 muzaffar 1.34 %define oraclesdksrc none
13     %else
14     # we still need oracle sdk makefiles:
15     %define oraclesdksrc http://cmsrep.cern.ch/cmssw/oracle-mirror/slc4_ia32/10.2.0.3/sdk.zip
16     %endif
17    
18     Source0: http://mirror.switch.ch/ftp/mirror/CPAN/authors/id/P/PY/PYTHIAN/%downloadn-%{realversion}.tar.gz
19     Source1: %oraclesdksrc
20    
21 lat 1.8 Provides: perl(Tk) perl(Tk::Balloon) perl(Tk::ErrorDialog) perl(Tk::FileSelect) perl(Tk::Pod) perl(Tk::ROText)
22 lat 1.5
23 eulisse 1.1 %prep
24 muzaffar 1.34 %setup -T -b 0 -n %{downloadn}-%{realversion}
25    
26     %if "%online" == "true"
27     rm -rf instantclient_*
28     yes | unzip %_sourcedir/sdk.zip
29     %endif
30 lat 1.4
31 eulisse 1.1 %build
32 andreasp 1.33 patch Makefile.PL << \EOF
33     diff Makefile.PL.orig Makefile.PL
34     1407a1408
35     > "$OH/include", # Tim Barrass, hacked for OIC install from zips
36     EOF
37 lat 1.4 %ifos darwin
38 andreasp 1.33 perl -p -i -e 's/NMEDIT = nmedit/NMEDIT = true/' Makefile.PL
39 lat 1.4 %endif
40 ratnik 1.21
41 muzaffar 1.34 %if "%online" != "true"
42 andreasp 1.33 perl Makefile.PL PREFIX=%i LIB=%i/lib/site_perl/%perlversion -l -m $ORACLE_HOME/demo/demo.mk
43 muzaffar 1.34 %else
44     export ORACLE_HOME="/opt/xdaq"
45     perl Makefile.PL PREFIX=%i LIB=%i/lib/site_perl/%perlversion -l -m instantclient_10_2/demo/demo.mk
46     %endif
47 eulisse 1.1 make