ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/p5-dbd-oracle.spec
Revision: 1.29
Committed: Thu Nov 20 12:52:58 2008 UTC (16 years, 5 months ago) by fvlingen
Branch: MAIN
CVS Tags: WEBTOOLS-APPS_20090130, WEBTOOLS-APPS_20090129, PRODAGENT_0_12_10_pre3, PRODAGENT_0_12_10_pre2_20090127_V2, PRODAGENT_0_12_10_20090122, PRODAGENT_0_12_10_pre1_MISC, sw_20090115a, sw_20090115, PRODAGENT_0_12_9_patch1_20081219, PRODAGENT_0_12_10_20081219, PRODAGENT_0_12_9_20081218, PRODAGENT_0_12_8_20081211, PRODAGENT_0_12_8_pre1_20081129, testofc, PRODAGENT_BUILD_TEST_0_0_5_20081120, PRODAGENT_BUILD_TEST_0_0_5_APP
Changes since 1.28: +1 -1 lines
Log Message:
build it from scratch

File Contents

# Content
1 ### RPM external p5-dbd-oracle 1.17-CMS24
2 ## INITENV +PATH PERL5LIB %i/lib/site_perl/%perlversion
3
4 %define perlversion %(perl -e 'printf "%%vd", $^V')
5 %define perlarch %(perl -MConfig -e 'print $Config{archname}')
6 %define downloadn DBD-Oracle
7
8 %if "%cmsplatf" != "slc4onl_ia32_gcc346"
9 Requires: p5-dbi oracle
10 %define oraclesdksrc none
11 %else
12 # we still need oracle sdk makefiles:
13 %define oraclesdksrc http://cmsrep.cern.ch/cmssw/oracle-mirror/slc4_ia32/10.2.0.3/sdk.zip
14 %endif
15
16 Source0: http://mirror.switch.ch/ftp/mirror/CPAN/authors/id/P/PY/PYTHIAN/%downloadn-%{realversion}.tar.gz
17 Source1: %oraclesdksrc
18
19 Provides: perl(Tk) perl(Tk::Balloon) perl(Tk::ErrorDialog) perl(Tk::FileSelect) perl(Tk::Pod) perl(Tk::ROText)
20
21 %prep
22 %setup -T -b 0 -n %{downloadn}-%{realversion}
23
24 %if "%cmsplatf" == "slc4onl_ia32_gcc346"
25 rm -rf instantclient_*
26 yes | unzip %_sourcedir/sdk.zip
27 %endif
28
29 %build
30 %ifos darwin
31 perl -p -i -e 's/NMEDIT = nmedit/NMEDIT = true/' Makefile.PL
32 %endif
33
34 %if "%cmsplatf" != "slc4onl_ia32_gcc346"
35 perl Makefile.PL PREFIX=%i LIB=%i/lib/site_perl/%perlversion -l -m $ORACLE_HOME/demo/demo.mk
36 %else
37 export ORACLE_HOME="/opt/xdaq"
38 perl Makefile.PL PREFIX=%i LIB=%i/lib/site_perl/%perlversion -l -m instantclient_10_2/demo/demo.mk
39 %endif
40 make