ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/p5-log-log4perl.spec
Revision: 1.3
Committed: Tue Mar 31 07:16:45 2009 UTC (16 years, 1 month ago) by muzaffar
Branch: MAIN
CVS Tags: dg20100416-prodagent, dg20100326-prodagent, DAS_20100302_slc5_amd64_gcc434, DBS_20100226_slc5_amd64_gcc434, sw_20100218, DBS_20100217_slc5_amd64_gcc434, FILEMOVER_20100217_slc5_amd64_gcc434, DAS_20100217_slc5_amd64_gcc434, DAS_20100216b_slc5_amd64_gcc434, DAS_20100216_slc5_amd64_gcc434, dg20100201-dbs3, FILEMOVER_20100201_slc5_amd64_gcc434, FILEMOVER_20100128b_slc5_amd64_gcc434, dg20100129-dbs3, dg20100128-dbs3, FILEMOVER_20100128_slc5_amd64_gcc434, DAS_20100127_slc5_amd64_gcc434, DAS_20100126_slc5_amd64_gcc434, dg20100125-prodagent, FILEMOVER_20100122_slc5_amd64_gcc434, DAS_20100119_slc5_amd64_gcc434, DAS_20100115_slc5_amd64_gcc434, dg20100115-security, DBS_20100115_slc5_amd64_gcc434, dg20100112-security, DBS_20100112_slc5_amd64_gcc434, DBS_20100111_slc5_amd64_gcc434, dg20100111-security, dg20100107b-wmcore, dg20100107-wmcore, dg20100106b-prodagent, dg20100106-prodagent, DAS_20100105_slc5_amd64_gcc434, DAS_20091221_slc5_amd64_gcc434, DAS_20091214_slc5_amd64_gcc434, dg20091211-couchdb, dg20091203c-comp-base, DD_20091208_slc5_amd64_gcc434, DAS_20091208_slc5_amd64_gcc434, FILEMOVER_20091208_slc5_amd64_gcc434, DBS_20091208_slc5_amd64_gcc434, dg20091203b-comp-base, dg20091203-comp-base, DQMCATTEST_0_0_1, DAS_20091117, PRODAGENT_0_12_17_pre2, BUILDBOT_01, CERNOIDv02, PRODAGENT_0_12_17_pre1, CouchDB_0_10_0, PRODAGENT_0_12_16_patch2, PRODAGENT_0_12_16_patch1, CERNOIDv01, sjg091014a, WMCORE-before-refactor, PerfSuiteDB_20090930, PRODAGENT_0_12_16, sm090924a, PerfSuiteDB_20090916, PerfSuiteDB_20090904_almost_stable, PerfSuiteDB_20090904, PerfSuiteDB_20090901, forHEARTBEATr04, RPMVERIFY_0_2, forHEARTBEATr01, sm090807a, PRODAGENT_0_12_15_patch1, sm090703b, PRODAGENT_0_12_15, ap20090520-osx105, ap20090519-osx105, PRODAGENT_0_12_14-dbs206p5-090507, PRODAGENT_0_12_15_pre2-090507, PRODAGENT_0_12_15_pre2, sm090506c, PRODAGENT_0_12_14-dbs206p5, sm090506b, sm090506a, PRODAGENT_0_12_13_patch5_DBS206a, PRODAGENT_0_12_14, PRODAGENT_0_12_13_patch5_DBS206, sm090408a, PRODAGENT_0_12_13_patch5, sm090331a_pa0_12_13-p5, PRODAGENT_0_12_13_patch5_V1_20090331, sm090331_pa0_12_13-p5
Changes since 1.2: +29 -3 lines
Log Message:
fixed 64bit perl issue by building all perl modules using system compiler too

File Contents

# User Rev Content
1 egeland 1.1 ### RPM external p5-log-log4perl 1.16
2     ## INITENV +PATH PERL5LIB %i/lib/site_perl/%perlversion
3 muzaffar 1.3 %define perl /usr/bin/env perl
4     %if "%(echo %cmsplatf | cut -f1 -d_ | sed -e 's|\([A-Za-z]*\)[0-9]*|\1|')" == "osx"
5     %define perl /usr/bin/perl
6     %endif
7    
8     %define perlversion %(%perl -e 'printf "%%vd", $^V')
9     %define perlarch %(%perl -MConfig -e 'print $Config{archname}')
10 egeland 1.1 %define downloadn Log-Log4perl
11    
12 egeland 1.2 Source: http://search.cpan.org/CPAN/authors/id/M/MS/MSCHILLI/%{downloadn}-%{realversion}.tar.gz
13     Requires: p5-log-dispatch p5-log-dispatch-filerotate
14 egeland 1.1
15     # Provided by system perl
16     Provides: perl(XML::DOM)
17    
18     # Fake provides for optional backends
19     Provides: perl(RRDs)
20 egeland 1.2 Provides: perl(DBI)
21 egeland 1.1
22    
23     %prep
24 egeland 1.2 %setup -n %downloadn-%realversion
25 egeland 1.1 %build
26     LC_ALL=C; export LC_ALL
27 muzaffar 1.3 %perl Makefile.PL PREFIX=%i LIB=%i/lib/site_perl/%perlversion
28 egeland 1.1 make
29     #
30 muzaffar 1.3 case %{cmsos} in
31     slc4_ia32)
32     if ldd /usr/bin/gcc | grep -q /lib64/
33     then
34     make install
35     mv %i/lib/site_perl/%perlversion/x86_64-linux-thread-multi %i/lib/site_perl/%perlversion/i386-linux-thread-multi
36     make clean
37     export PATH=/usr/bin/:$PATH
38     export GCC_EXEC_PREFIX=/usr/lib/gcc/
39     %perl Makefile.PL PREFIX=%i LIB=%i/lib/site_perl/%perlversion
40     make
41     make install
42     else
43     make install
44     fi;;
45     *)
46     make install
47     ;;
48     esac
49    
50     %install