Revision: | 1.2 |
Committed: | Tue Nov 18 11:13:32 2008 UTC (16 years, 5 months ago) by fvlingen |
Branch: | MAIN |
CVS Tags: | WEBTOOLS-APPS_20090130, WEBTOOLS-APPS_20090129, sw_20090115a, sw_20090115, PRODAGENT_0_12_9_patch1_20081219, PRODAGENT_0_12_10_20081219, PRODAGENT_0_12_9_20081218, PRODAGENT_0_12_8_20081211, PRODAGENT_0_12_8_pre1_20081129, testofc, PRODAGENT_BUILD_TEST_0_0_5_20081120, PRODAGENT_BUILD_TEST_0_0_5_APP, PRODAGENT_BUILD_TEST_0_0_4_20081120, PRODAGENT_BUILD_TEST_0_0_3_20081120_V1, PRODAGENT_BUILD_TEST_0_0_3_APP, PRODAGENT_BUILD_TEST_0_0_3_20081120, PRODAGENT_0_12_7_20081118_V3, PRODAGENT_0_12_7_20081118_V2, PRODAGENT_0_12_7_20081118_V1, PRODAGENT_0_12_7_APP |
Changes since 1.1: | +7 -2 lines |
Log Message: | quick hack to force download correct version |
# | User | Rev | Content |
---|---|---|---|
1 | egeland | 1.1 | ### RPM external p5-params-validate 0.91 |
2 | ## INITENV +PATH PERL5LIB %i/lib/site_perl/%perlversion | ||
3 | %define perlversion %(perl -e 'printf "%%vd", $^V') | ||
4 | %define perlarch %(perl -MConfig -e 'print $Config{archname}') | ||
5 | %define downloadn Params-Validate | ||
6 | |||
7 | fvlingen | 1.2 | # There where some problems using the parameterized version |
8 | # with cmsbuild so I substituted the hard values. | ||
9 | # the commented out lines are from the original (fvlingen@caltech.edu) | ||
10 | #Source: http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/%{downloadn}-%{v}.tar.gz | ||
11 | Source: http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/Params-Validate-0.91.tar.gz | ||
12 | egeland | 1.1 | |
13 | %prep | ||
14 | fvlingen | 1.2 | #%setup -n %downloadn-%v |
15 | %setup -n Params-Validate-0.91 | ||
16 | egeland | 1.1 | %build |
17 | LC_ALL=C; export LC_ALL | ||
18 | perl Makefile.PL PREFIX=%i LIB=%i/lib/site_perl/%perlversion | ||
19 | make | ||
20 | # |