ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/p5-template-toolkit.spec
Revision: 1.13
Committed: Wed May 16 09:41:05 2007 UTC (17 years, 11 months ago) by eulisse
Branch: MAIN
CVS Tags: ge20070629, pe20070626c-ports, ge20070625, pe20070626b-ports, sm20070626a-ports, pe20070626a-ports, pe20070625b-ports, pe20070625a-ports, pe20070624a-ports, ge20070622, pe20070607a-ports, pe20070522a-ports
Changes since 1.12: +1 -2 lines
Log Message:
* Updated to 2.15, which now does not depend on perl DBI anymore, so that
  we can drop the dependency. This simplifies the deployment of scram,
  since DBI is a binary module that had to be compiled both for 64 and 32
  bit.

File Contents

# User Rev Content
1 eulisse 1.13 ### RPM external p5-template-toolkit 2.15
2 eulisse 1.1 ## INITENV +PATH PATH %{i}/bin
3 eulisse 1.8 ## INITENV +PATH PERL5LIB %i/lib/site_perl/%perlversion
4 lat 1.4 %define perlversion %(perl -e 'printf "%%vd", $^V')
5     %define perlarch %(perl -MConfig -e 'print $Config{archname}')
6 eulisse 1.1 %define downloadn Template-Toolkit
7 eulisse 1.2
8     Provides: perl(AppConfig)
9     Provides: perl(GD)
10     Provides: perl(GD::Graph::area)
11     Provides: perl(GD::Graph::bars)
12     Provides: perl(GD::Graph::bars3d)
13     Provides: perl(GD::Graph::lines)
14     Provides: perl(GD::Graph::lines3d)
15     Provides: perl(GD::Graph::linespoints)
16     Provides: perl(GD::Graph::mixed)
17     Provides: perl(GD::Graph::pie)
18     Provides: perl(GD::Graph::pie3d)
19     Provides: perl(GD::Graph::points)
20     Provides: perl(GD::Text)
21     Provides: perl(GD::Text::Align)
22     Provides: perl(GD::Text::Wrap)
23     Provides: perl(Pod::POM)
24     Provides: perl(Text::Autoformat)
25     Provides: perl(XML::DOM)
26     Provides: perl(XML::RSS)
27     Provides: perl(XML::Simple)
28     Provides: perl(XML::XPath)
29 eulisse 1.1 Source: http://www.cpan.org/modules/by-module/Template/%downloadn-%v.tar.gz
30    
31     %prep
32     %setup -n %{downloadn}-%{v}
33     %build
34 lat 1.4 perl Makefile.PL PREFIX=%i LIB=%i/lib/site_perl/%perlversion \
35     TT_LIB=%{i}/lib/site_perl/%perlversion \
36 eulisse 1.1 TT_PREFIX=%{i} \
37     TT_ACCEPT=y \
38     TT_DOCS=n \
39 eulisse 1.12 TT_EXAMPLES=n \
40     TT_SPLASH=n \
41     TT_DBI=n
42     perl -p -i -e 's!install :: (.*) tt2_splash!install :: $1!' Makefile
43 eulisse 1.1 make
44 elmer 1.7 perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' blib/script/tpage
45     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' blib/script/ttree
46 eulisse 1.12 case %{cmsos} in
47     slc4_ia32)
48     if ldd /usr/bin/gcc | grep -q /lib64/
49     then
50     make install
51     mv %i/lib/site_perl/%perlversion/x86_64-linux-thread-multi %i/lib/site_perl/%perlversion/i386-linux-thread-multi
52     make clean
53     export PATH=/usr/bin/:$PATH
54     export GCC_EXEC_PREFIX=/usr/lib/gcc/
55     perl Makefile.PL PREFIX=%i LIB=%i/lib/site_perl/%perlversion \
56     TT_LIB=%{i}/lib/site_perl/%perlversion \
57     TT_PREFIX=%{i} \
58     TT_ACCEPT=y \
59     TT_DOCS=n \
60     TT_EXAMPLES=n \
61     TT_SPLASH=n \
62     TT_DBI=n
63     perl -p -i -e 's!install :: (.*) tt2_splash!install :: $1!' Makefile
64     make
65     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' blib/script/tpage
66     perl -p -i -e 's|^#!.*perl(.*)|#!/usr/bin/env perl$1|' blib/script/ttree
67     fi;;
68     *)
69     ;;
70     esac
71 elmer 1.7
72 eulisse 1.1 %install
73     make install