ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/p5-xml-parser.spec
Revision: 1.12
Committed: Tue May 15 16:46:43 2007 UTC (17 years, 11 months ago) by eulisse
Branch: MAIN
Changes since 1.11: +20 -5 lines
Log Message:
* on slc4_ia32, if a 64 bit compiler is found in /usr/bin, both 32 and 64
 bit version of the perl modules needed to run scram will be build and
 packaged.

File Contents

# User Rev Content
1 eulisse 1.1 ### RPM external p5-xml-parser 2.34
2 eulisse 1.8 ## INITENV +PATH PERL5LIB %i/lib/site_perl/%perlversion
3 lat 1.5 %define perlversion %(perl -e 'printf "%%vd", $^V')
4     %define perlarch %(perl -MConfig -e 'print $Config{archname}')
5 eulisse 1.1 %define downloadn XML-Parser
6 lat 1.6 Requires: expat
7 eulisse 1.1 Source: http://mirror.switch.ch/ftp/mirror/CPAN/authors/id/M/MS/MSERGEANT/%{downloadn}-%{v}.tar.gz
8     %prep
9     %setup -n %downloadn-%v
10     %build
11 eulisse 1.12
12 lat 1.5 perl Makefile.PL PREFIX=%i LIB=%i/lib/site_perl/%perlversion \
13 eulisse 1.3 EXPATLIBPATH=$EXPAT_ROOT/lib \
14     EXPATINCPATH=$EXPAT_ROOT/include
15 eulisse 1.1 make
16 eulisse 1.12
17     case %{cmsos} in
18     slc4_ia32)
19     if ldd /usr/bin/gcc | grep -q /lib64/
20     then
21     make install
22     mv %i/lib/site_perl/%perlversion/x86_64-linux-thread-multi %i/lib/site_perl/%perlversion/i386-linux-thread-multi
23     make clean
24    
25     export PATH=/usr/bin/:$PATH
26     export GCC_EXEC_PREFIX=/usr/lib/gcc/
27     perl Makefile.PL PREFIX=%i LIB=%i/lib/site_perl/%perlversion \
28     EXPATLIBPATH=$EXPAT_ROOT/lib64 \
29     EXPATINCPATH=$EXPAT_ROOT/include
30     make
31     fi;;
32     *)
33     ;;
34 elmer 1.7 esac
35 eulisse 1.12
36 eulisse 1.1 %install
37     make install