ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/p5-xml-parser.spec
Revision: 1.19
Committed: Thu Dec 27 20:28:33 2007 UTC (17 years, 4 months ago) by elmer
Branch: MAIN
CVS Tags: pe20080108c-ports, ge20080108-wt, pe20080108b-ports, pe20080108a-ports, pe20080105a-ports, pe20080104a-ports, pe20080103a-ports-gcc422, pe20080103a-ports, pe20070103a-ports, pe20080101a-ports, pe20071128b-ports, pe20071128a-ports, pe20071127b-ports
Changes since 1.18: +1 -1 lines
Log Message:
Update to -CMS19 (and variants) and CMS_152.
SCRAMV1 was updated to V1_0_3-p4

File Contents

# User Rev Content
1 elmer 1.19 ### RPM external p5-xml-parser 2.34-CMS19
2 eulisse 1.8 ## INITENV +PATH PERL5LIB %i/lib/site_perl/%perlversion
3 lat 1.5 %define perlversion %(perl -e 'printf "%%vd", $^V')
4     %define perlarch %(perl -MConfig -e 'print $Config{archname}')
5 eulisse 1.1 %define downloadn XML-Parser
6 eulisse 1.13 %define expatversion 2.0.0
7 elmer 1.14 Source0: http://mirror.switch.ch/ftp/mirror/CPAN/authors/id/M/MS/MSERGEANT/%{downloadn}-%{realversion}.tar.gz
8 eulisse 1.13 Source1: http://dl.sourceforge.net/sourceforge/expat/expat-%expatversion.tar.gz
9 elmer 1.17 Provides: libc.so.6()(64bit)
10     Provides: libc.so.6(GLIBC_2.2.5)(64bit)
11    
12 eulisse 1.1 %prep
13 elmer 1.14 %setup -T -b 0 -n %{downloadn}-%{realversion}
14 eulisse 1.13 %setup -D -T -b 1 -n expat-%expatversion
15 eulisse 1.1 %build
16 eulisse 1.13 # We statically compile expat so that the perl module itself,
17     # and hence scram, do not depend on the expat rpm.
18     # This way we can change the expat version in CMSSW/externals
19     # without having to rebuild scram.
20     which gcc
21     rm -rf %_builddir/tmp
22     cd ../expat-%expatversion
23     mkdir -p %_builddir/tmp
24 elmer 1.16 ./configure --prefix=%_builddir/tmp --disable-shared --enable-static --with-pic
25 eulisse 1.13 make clean
26     make
27     make install
28 elmer 1.14 cd ../%{downloadn}-%{realversion}
29 eulisse 1.12
30 lat 1.5 perl Makefile.PL PREFIX=%i LIB=%i/lib/site_perl/%perlversion \
31 eulisse 1.13 EXPATLIBPATH=%_builddir/tmp/lib \
32     EXPATINCPATH=%_builddir/tmp/include
33 eulisse 1.1 make
34 eulisse 1.12
35 eulisse 1.13 # If we are building on a machine which has a system compiler which
36     # can produce 64 bit binaries, than we also compile a 64 bit version
37     # of the module, so that scram can work also on 64bit platforms disguised
38     # as 32 bit via linux32.
39 eulisse 1.12 case %{cmsos} in
40     slc4_ia32)
41     if ldd /usr/bin/gcc | grep -q /lib64/
42     then
43     make install
44     mv %i/lib/site_perl/%perlversion/x86_64-linux-thread-multi %i/lib/site_perl/%perlversion/i386-linux-thread-multi
45     make clean
46    
47     export PATH=/usr/bin/:$PATH
48     export GCC_EXEC_PREFIX=/usr/lib/gcc/
49 eulisse 1.13 cd ../expat-%expatversion
50     CXX="/usr/bin/c++ -fPIC" CC="/usr/bin/gcc -fPIC" setarch x86_64 ./configure --prefix=%_builddir/tmp --bindir=%_builddir/tmp/bin/64 --libdir=%_builddir/tmp/lib64 --disable-shared --enable-static
51     echo "Building 64bit version"
52     setarch x86_64 make clean
53     setarch x86_64 make
54     setarch x86_64 make install
55 elmer 1.14 cd ../%{downloadn}-%{realversion}
56 eulisse 1.12 perl Makefile.PL PREFIX=%i LIB=%i/lib/site_perl/%perlversion \
57 eulisse 1.13 EXPATLIBPATH=%_builddir/tmp/lib64 \
58     EXPATINCPATH=%_builddir/tmp/include
59 eulisse 1.12 make
60 eulisse 1.13 make install
61 eulisse 1.15 else
62     make install
63 eulisse 1.12 fi;;
64     *)
65 eulisse 1.15 make install
66 eulisse 1.12 ;;
67 elmer 1.7 esac
68 eulisse 1.12
69 eulisse 1.1 %install