ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/p5-xml-parser.spec
Revision: 1.18
Committed: Fri Nov 2 18:24:54 2007 UTC (17 years, 6 months ago) by elmer
Branch: MAIN
CVS Tags: CMSSW_1_8_4, pe20080405-for184, CMSSW_1_8_3, pe20080326-for183, pe20080325-for183, CMSSW_1_8_2, pe20080324-for182, nr080320a, CMSSW_1_8_1, nr080314_181onl1, pe20080314-for181, CMSSW_1_8_0_ONLINE1, nr080310_180onl1, nr080307onl180onl1, CMSSW_1_8_0, pe20080304a-for180, pe20080303a-for18X, CMSSW_1_8_0_pre10, pe20080226-for180p10, pe20080220a-for18X, CMSSW_1_8_0_pre9, nr080215g491p01dbg, CMSSW_2_0_0_pre1, CMSSW_1_8_0_pre8, dl080202, pe20080126-for180p8, CMSSW_1_8_0_pre7, pe20080122a-for180p7, dl080120, pe20080120a-for180p7, pe20080117b-for180p7, pe20080117-for180p7, dl080115, CMSSW_1_8_0_pre6, NR080108_geant491-dbg-global, sm20080101a-newscram, pe20071127-ports, pe20071226c-for180p6, pe20071226b-for180p6, pe20071226a-for180p6, ge20071224, ge20071223, ge20071221, pe20071220b-for180p6, ge20071220, pe20071220-for180p6, ge20071217, CMSSW_1_8_0_pre5, pe20071216-for180p5, ge20071216, CMSSW_1_8_0_pre4-vg330, ge20071213, ge20071212-perfreport, ge20071212, ge20071211, ge20071210a, ge20071210, pe20071207-for180p4g491c3, NR071206_geant491cand3-global, ge20071207, pe20071206-for180test1, CMSSW_1_8_0_pre4-412, CMSSW_1_8_0_pre4, pe20071205b-for180p4-412, pe20071205b-for180p4, pe20071205-for180p4, ge20071205, CMSSW_1_8_0_pre3a-412, ge20071203, pe20071202-for180p3a-gcc412, CMSSW_1_8_0_pre3a, pe20071201b-for180p3a, pe20071201-for180p3a, V00-06-08, ge20071128, pe20071130-for180p3, pe20071129-for180p3, ge20071127a-leopard, ge20071127-leopard, pe20071127a-ports-412, ge20071126-new-bootstrap, CMSSW_1_8_0_pre2, CMSSW_1_8_0_pre0-amd64, CMSSW_1_8_0_pre0, pe20071123e-ports-412, pe20071123d-ports-412, pe20071123c-ports-422, pe20071123c-ports-412, pe20071123c-ports, pe20071123b-ports-422, pe20071123b-ports-412, pe20071123b-ports, pe20071123a-ports-422, pe20071123a-ports-412, pe20071123a-ports, ge20071122-new-bootstrap, pe20071121a-ports-422, pe20071121a-ports-412, pe20071121a-ports, pe20071112c-ports-422, pe20071112c-ports-412, pe20071112c-ports, pe20071112b-ports-412, pe20071112b-ports, pe20071112a-ports, pe20071105c-ports, pe20071105b-ports, pe20071105a-ports, pe20071103e-ports, pe20071103d-ports, pe20071103c-ports, pe20071103b-ports, pe20071103a-ports, pe20071102b-ports
Changes since 1.17: +1 -1 lines
Log Message:
Update to -CMS18

File Contents

# Content
1 ### RPM external p5-xml-parser 2.34-CMS18
2 ## INITENV +PATH PERL5LIB %i/lib/site_perl/%perlversion
3 %define perlversion %(perl -e 'printf "%%vd", $^V')
4 %define perlarch %(perl -MConfig -e 'print $Config{archname}')
5 %define downloadn XML-Parser
6 %define expatversion 2.0.0
7 Source0: http://mirror.switch.ch/ftp/mirror/CPAN/authors/id/M/MS/MSERGEANT/%{downloadn}-%{realversion}.tar.gz
8 Source1: http://dl.sourceforge.net/sourceforge/expat/expat-%expatversion.tar.gz
9 Provides: libc.so.6()(64bit)
10 Provides: libc.so.6(GLIBC_2.2.5)(64bit)
11
12 %prep
13 %setup -T -b 0 -n %{downloadn}-%{realversion}
14 %setup -D -T -b 1 -n expat-%expatversion
15 %build
16 # We statically compile expat so that the perl module itself,
17 # and hence scram, do not depend on the expat rpm.
18 # This way we can change the expat version in CMSSW/externals
19 # without having to rebuild scram.
20 which gcc
21 rm -rf %_builddir/tmp
22 cd ../expat-%expatversion
23 mkdir -p %_builddir/tmp
24 ./configure --prefix=%_builddir/tmp --disable-shared --enable-static --with-pic
25 make clean
26 make
27 make install
28 cd ../%{downloadn}-%{realversion}
29
30 perl Makefile.PL PREFIX=%i LIB=%i/lib/site_perl/%perlversion \
31 EXPATLIBPATH=%_builddir/tmp/lib \
32 EXPATINCPATH=%_builddir/tmp/include
33 make
34
35 # If we are building on a machine which has a system compiler which
36 # can produce 64 bit binaries, than we also compile a 64 bit version
37 # of the module, so that scram can work also on 64bit platforms disguised
38 # as 32 bit via linux32.
39 case %{cmsos} in
40 slc4_ia32)
41 if ldd /usr/bin/gcc | grep -q /lib64/
42 then
43 make install
44 mv %i/lib/site_perl/%perlversion/x86_64-linux-thread-multi %i/lib/site_perl/%perlversion/i386-linux-thread-multi
45 make clean
46
47 export PATH=/usr/bin/:$PATH
48 export GCC_EXEC_PREFIX=/usr/lib/gcc/
49 cd ../expat-%expatversion
50 CXX="/usr/bin/c++ -fPIC" CC="/usr/bin/gcc -fPIC" setarch x86_64 ./configure --prefix=%_builddir/tmp --bindir=%_builddir/tmp/bin/64 --libdir=%_builddir/tmp/lib64 --disable-shared --enable-static
51 echo "Building 64bit version"
52 setarch x86_64 make clean
53 setarch x86_64 make
54 setarch x86_64 make install
55 cd ../%{downloadn}-%{realversion}
56 perl Makefile.PL PREFIX=%i LIB=%i/lib/site_perl/%perlversion \
57 EXPATLIBPATH=%_builddir/tmp/lib64 \
58 EXPATINCPATH=%_builddir/tmp/include
59 make
60 make install
61 else
62 make install
63 fi;;
64 *)
65 make install
66 ;;
67 esac
68
69 %install