1 |
eulisse |
1.1 |
|
2 |
|
|
### RPM cms pkgtools V00-01-00
|
3 |
|
|
## INITENV ALIAS cmsbuild install.sh -spec_dir ./inst-files
|
4 |
|
|
# This generates an rpm for aptinstaller, install.sh, etc. etc.
|
5 |
|
|
Requires: cms-env
|
6 |
|
|
%define moduleName PKGTOOLS
|
7 |
|
|
%define exportName PKGTOOLS
|
8 |
|
|
%define cvstag V00-01-00
|
9 |
|
|
%define cvsserver cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e
|
10 |
|
|
Source: %cvsserver&module=%{moduleName}&export=%{exportName}&tag=-r%{cvstag}&output=/PKGTOOLS.tar.gz
|
11 |
|
|
|
12 |
|
|
%prep
|
13 |
|
|
%setup -n PKGTOOLS
|
14 |
|
|
%build
|
15 |
|
|
%install
|
16 |
|
|
make PREFIX=%{i} install
|
17 |
|
|
mkdir -p %{instroot}/%{cmsplatf}/etc/profile.d
|
18 |
|
|
ln -sf %{i}/etc/profile.d/init.sh %{instroot}/%{cmsplatf}/etc/profile.d/S00pkgtools.sh
|
19 |
|
|
ln -sf %{i}/etc/profile.d/init.csh %{instroot}/%{cmsplatf}/etc/profile.d/S00pkgtools.csh
|
20 |
|
|
ln -sf %{i}/inst-files %{instroot}/inst-files
|
21 |
|
|
%files
|
22 |
|
|
%{i}
|
23 |
|
|
%{instroot}/%{cmsplatf}/etc/profile.d/S00pkgtools.sh
|
24 |
|
|
%{instroot}/%{cmsplatf}/etc/profile.d/S00pkgtools.csh
|
25 |
|
|
|
26 |
|
|
%post
|
27 |
|
|
ln -sf $RPM_INSTALL_PREFIX/%{pkgrel}/etc/profile.d/init.sh $RPM_INSTALL_PREFIX/%cmsplatf/etc/profile.d/S00pkgtools.sh
|
28 |
|
|
ln -sf $RPM_INSTALL_PREFIX/%{pkgrel}/etc/profile.d/init.csh $RPM_INSTALL_PREFIX/%cmsplatf/etc/profile.d/S00pkgtools.csh
|
29 |
|
|
ln -sf $RPM_INSTALL_PREFIX/%{pkgrel}/inst-files $RPM_INSTALL_PREFIX/inst-files
|