Revision: | 1.17 |
Committed: | Tue May 1 11:09:39 2007 UTC (18 years ago) by elmer |
Branch: | MAIN |
CVS Tags: | ge20070629, CMSSW_1_6_0_pre1, pe20070729b-160p2, pe20070729b-160p1, pe20070729a-160p2, pe20070729a-160p1, pe20070629a-ports, pe20070628e-ports, pe20070628d-ports, pe20070628c-ports, pe20070628b-ports, pe20070628a-ports, pe20070627b-ports, pe20070627a-ports, pe20070626c-ports, ge20070625, pe20070626b-ports, sm20070626a-ports, pe20070626a-ports, pe20070625b-ports, pe20070625a-ports, pe20070624a-ports, ge20070622, pe20070607a-ports, pe20070522a-ports, pe20070519a-ports, pe20070512a-ports, pe20070508a-ports, pe20070507a-ports, pe20070501c-ports, pe20070501b-ports, pe20070501a-ports |
Changes since 1.16: | +0 -2 lines |
Log Message: | Remove gcc-wrappers |
# | User | Rev | Content |
---|---|---|---|
1 | eulisse | 1.2 | ### RPM cms pkgtools 1.0 |
2 | ## INITENV ALIAS cmsbuild %{i}/bin/install.sh -spec_dir ./inst-files | ||
3 | ## INITENV ALIAS_SH cmsapt eval `%{i}/bin/aptinstaller.sh config -path %{instroot} -sh` | ||
4 | ## INITENV ALIAS_CSH cmsapt eval `%{i}/bin/aptinstaller.sh config -path %{instroot} -csh` | ||
5 | eulisse | 1.5 | ## INITENV ALIAS updateAptRepository %{i}/bin/updateServer.sh |
6 | eulisse | 1.1 | |
7 | # This generates an rpm for aptinstaller, install.sh, etc. etc. | ||
8 | Requires: cms-env | ||
9 | %define moduleName PKGTOOLS | ||
10 | %define exportName PKGTOOLS | ||
11 | eulisse | 1.15 | %define cvstag V00-04-07 |
12 | eulisse | 1.1 | %define cvsserver cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e |
13 | eulisse | 1.4 | Source: %cvsserver&strategy=checkout&module=%{moduleName}&nocache=true&export=%{exportName}&tag=-r%{cvstag}&output=/PKGTOOLS.tar.gz |
14 | eulisse | 1.1 | |
15 | %prep | ||
16 | %setup -n PKGTOOLS | ||
17 | %build | ||
18 | %install | ||
19 | make PREFIX=%{i} install | ||
20 | mkdir -p %{instroot}/%{cmsplatf}/etc/profile.d | ||
21 | ln -sf %{i}/etc/profile.d/init.sh %{instroot}/%{cmsplatf}/etc/profile.d/S00pkgtools.sh | ||
22 | ln -sf %{i}/etc/profile.d/init.csh %{instroot}/%{cmsplatf}/etc/profile.d/S00pkgtools.csh | ||
23 | ln -sf %{i}/inst-files %{instroot}/inst-files | ||
24 | %files | ||
25 | %{i} | ||
26 | %{instroot}/%{cmsplatf}/etc/profile.d/S00pkgtools.sh | ||
27 | %{instroot}/%{cmsplatf}/etc/profile.d/S00pkgtools.csh | ||
28 | |||
29 | %post | ||
30 | eulisse | 1.2 | perl -p -i -e 's|(.*setenv.*)|#$1|' $RPM_INSTALL_PREFIX/%pkgrel/etc/profile.d/init.csh |
31 | perl -p -i -e 's|(.*export.*)|#$1|' $RPM_INSTALL_PREFIX/%pkgrel/etc/profile.d/init.sh | ||
32 | eulisse | 1.1 | ln -sf $RPM_INSTALL_PREFIX/%{pkgrel}/etc/profile.d/init.sh $RPM_INSTALL_PREFIX/%cmsplatf/etc/profile.d/S00pkgtools.sh |
33 | ln -sf $RPM_INSTALL_PREFIX/%{pkgrel}/etc/profile.d/init.csh $RPM_INSTALL_PREFIX/%cmsplatf/etc/profile.d/S00pkgtools.csh |