1 |
fvlingen |
1.154 |
### RPM cms prodagent PRODAGENT_0_8_3_pre1
|
2 |
eulisse |
1.7 |
## INITENV +PATH PYTHONPATH %i/lib
|
3 |
afanfani |
1.135 |
#
|
4 |
elmer |
1.5 |
%define cvstag %v
|
5 |
|
|
Source: cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e&module=PRODAGENT&export=PRODAGENT&&tag=-r%{cvstag}&output=/PRODAGENT.tar.gz
|
6 |
fvlingen |
1.153 |
Requires: python mysql py2-mysqldb dbs-client boss prodcommon openssl cherrypy PHEDEX-micro py2-sqlalchemy
|
7 |
eulisse |
1.1 |
|
8 |
|
|
%prep
|
9 |
elmer |
1.5 |
%setup -n PRODAGENT
|
10 |
eulisse |
1.1 |
%build
|
11 |
|
|
%install
|
12 |
eulisse |
1.12 |
make PREFIX=%i install
|
13 |
eulisse |
1.18 |
mkdir -p %i/bin
|
14 |
elmer |
1.40 |
cp bin/prod* %{i}/bin
|
15 |
elmer |
1.51 |
mkdir -p %i/test
|
16 |
|
|
cp -R test/* %i/test/
|
17 |
elmer |
1.52 |
mkdir -p %i/util
|
18 |
|
|
cp -R util/* %i/util/
|
19 |
eulisse |
1.9 |
mkdir -p %{i}/etc/profile.d
|
20 |
eulisse |
1.15 |
mkdir -p %i/workdir
|
21 |
eulisse |
1.12 |
|
22 |
fvlingen |
1.155 |
(echo "#!/bin/sh"; \
|
23 |
|
|
echo "source $PYTHON_ROOT/etc/profile.d/init.sh"; \
|
24 |
|
|
echo "source $OPENSSL_ROOT/etc/profile.d/init.sh"; \
|
25 |
|
|
echo "source $MYSQL_ROOT/etc/profile.d/init.sh"; \
|
26 |
|
|
echo "source $PY2_MYSQLDB_ROOT/etc/profile.d/init.sh"; \
|
27 |
|
|
echo "source $DBS_CLIENT_ROOT/etc/profile.d/init.sh"; \
|
28 |
|
|
echo "source $PRODCOMMON_ROOT/etc/profile.d/init.sh"; \
|
29 |
|
|
echo "source $CHERRYPY_ROOT/etc/profile.d/init.sh"; \
|
30 |
|
|
echo "source $PHEDEX_MICRO_ROOT/etc/profile.d/init.sh"; \
|
31 |
|
|
echo "source $PY2_SQLALCHEMY_ROOT/etc/profile.d/init.sh"; \
|
32 |
|
|
echo "source $BOSS_ROOT/etc/profile.d/init.sh" ) > %{i}/etc/profile.d/dependencies-setup.sh
|
33 |
|
|
|
34 |
|
|
(echo "#!/bin/tcsh"; \
|
35 |
|
|
echo "source $PYTHON_ROOT/etc/profile.d/init.csh"; \
|
36 |
|
|
echo "source $OPENSSL_ROOT/etc/profile.d/init.csh"; \
|
37 |
|
|
echo "source $MYSQL_ROOT/etc/profile.d/init.csh"; \
|
38 |
|
|
echo "source $PY2_MYSQLDB_ROOT/etc/profile.d/init.csh"; \
|
39 |
|
|
echo "source $DBS_CLIENT_ROOT/etc/profile.d/init.csh"; \
|
40 |
|
|
echo "source $PRODCOMMON_ROOT/etc/profile.d/init.csh"; \
|
41 |
|
|
echo "source $CHERRYPY_ROOT/etc/profile.d/init.csh"; \
|
42 |
|
|
echo "source $PHEDEX_MICRO_ROOT/etc/profile.d/init.csh"; \
|
43 |
|
|
echo "source $PY2_SQLALCHEMY_ROOT/etc/profile.d/init.csh"; \
|
44 |
|
|
echo "source $BOSS_ROOT/etc/profile.d/init.csh" ) > %{i}/etc/profile.d/dependencies-setup.csh
|
45 |
afanfani |
1.81 |
|
46 |
eulisse |
1.14 |
|
47 |
eulisse |
1.9 |
%post
|
48 |
eulisse |
1.10 |
%{relocateConfig}etc/profile.d/dependencies-setup.sh
|
49 |
eulisse |
1.14 |
%{relocateConfig}etc/profile.d/dependencies-setup.csh
|