1 |
eulisse |
1.35 |
### RPM cms prodrequest 0.4.0
|
2 |
eulisse |
1.1 |
%define moduleName PRODREQUEST
|
3 |
|
|
%define exportName PRODREQUEST
|
4 |
eulisse |
1.40 |
%define cvstag V00-04-06
|
5 |
eulisse |
1.39 |
|
6 |
eulisse |
1.1 |
%define cvsserver cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e
|
7 |
|
|
Source: %cvsserver&strategy=checkout&module=%{moduleName}&nocache=true&export=%{exportName}&tag=-r%{cvstag}&output=/PRODREQUEST.tar.gz
|
8 |
eulisse |
1.31 |
Requires: python py2-sqlobject py2-pysqlite cherrypy py2-cheetah yui sqlite py2-formencode zlib expat openssl bz2lib db4 gdbm prodcommon webtools dbs dls boss mysql py2-mysqldb py2-pycrypto
|
9 |
|
|
#Requires: prodagent
|
10 |
eulisse |
1.1 |
|
11 |
|
|
%prep
|
12 |
eulisse |
1.6 |
%setup -n PRODREQUEST
|
13 |
eulisse |
1.1 |
%build
|
14 |
eulisse |
1.7 |
rm -rf %i/etc/profile.d
|
15 |
|
|
mkdir -p %i/etc/profile.d/
|
16 |
eulisse |
1.8 |
dependenciesRoots="$PYTHON_ROOT $SQLITE_ROOT $PY2_SQLOBJECT_ROOT $PY2_PYSQLITE_ROOT $CHERRYPY_ROOT $YUI_ROOT \
|
17 |
eulisse |
1.16 |
$ZLIB_ROOT $EXPAT_ROOT $OPENSSEL_ROOT $BZ2LIB_ROOT $DB4_ROOT $GDBM_ROOT $PY2_FORMENCODE_ROOT \
|
18 |
eulisse |
1.31 |
$PY2_CHEETAH_ROOT $PRODCOMMON_ROOT $WEBTOOLS_ROOT $DBS_ROOT $DLS_ROOT $BOSS_ROOT \
|
19 |
eulisse |
1.22 |
$PY2_MYSQLDB_ROOT $MYSQL_ROOT $PY2_PYCRYPTO_ROOT"
|
20 |
eulisse |
1.8 |
|
21 |
|
|
touch %i/etc/profile.d/dependencies-setup.sh
|
22 |
|
|
touch %i/etc/profile.d/dependencies-setup.csh
|
23 |
|
|
|
24 |
|
|
for pkg in $dependenciesRoots
|
25 |
|
|
do
|
26 |
|
|
echo $pkg
|
27 |
|
|
echo source $pkg/etc/profile.d/init.sh >> %i/etc/profile.d/dependencies-setup.sh
|
28 |
|
|
echo source $pkg/etc/profile.d/init.csh >> %i/etc/profile.d/dependencies-setup.csh
|
29 |
|
|
done
|
30 |
|
|
|
31 |
eulisse |
1.1 |
%install
|
32 |
|
|
cp -r * %i/
|
33 |
eulisse |
1.3 |
%post
|
34 |
eulisse |
1.8 |
%{relocateConfig}etc/profile.d/dependencies-setup.sh
|
35 |
|
|
%{relocateConfig}etc/profile.d/dependencies-setup.csh
|
36 |
eulisse |
1.6 |
perl -p -i -e "s!\@RPM_INSTALL_PREFIX\@!$RPM_INSTALL_PREFIX/%pkgrel!" $RPM_INSTALL_PREFIX/%pkgrel/PRODREQUEST
|
37 |
eulisse |
1.33 |
|