1 |
eulisse |
1.1 |
### RPM cms prodrequest V00-00-01
|
2 |
|
|
%define moduleName PRODREQUEST
|
3 |
|
|
%define exportName PRODREQUEST
|
4 |
|
|
%define cvstag %{v}
|
5 |
|
|
%define cvsserver cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e
|
6 |
|
|
Source: %cvsserver&strategy=checkout&module=%{moduleName}&nocache=true&export=%{exportName}&tag=-r%{cvstag}&output=/PRODREQUEST.tar.gz
|
7 |
eulisse |
1.5 |
Requires: python py2-sqlobject py2-pysqlite cherrypy py2-cheetah yui sqlite
|
8 |
eulisse |
1.1 |
|
9 |
|
|
%prep
|
10 |
|
|
%setup PRODREQUEST
|
11 |
|
|
%build
|
12 |
eulisse |
1.2 |
( echo source $PYTHON_ROOT/etc/profile.d/init.sh ; \
|
13 |
|
|
echo source $SQLITE_ROOT/etc/profile.d/init.sh ; \
|
14 |
eulisse |
1.4 |
echo source $PY2_SQLOBJECT_ROOT/etc/profile.d/init.sh ; \
|
15 |
eulisse |
1.2 |
echo source $PY2_PYSQLITE_ROOT/etc/profile.d/init.sh ; \
|
16 |
eulisse |
1.5 |
echo source $CHERRYPY_ROOT/etc/profile.d/init.sh ; \
|
17 |
eulisse |
1.2 |
echo source $PY2_CHEETAH_ROOT/etc/profile.d/init.sh ; \
|
18 |
eulisse |
1.4 |
echo source $YUI_ROOT/etc/profile.d/init.sh ; \
|
19 |
|
|
echo source $ZLIB_ROOT/etc/profile.d/init.sh ; \
|
20 |
|
|
echo source $EXPAT_ROOT/etc/profile.d/init.sh ; \
|
21 |
|
|
echo source $OPENSSL_ROOT/etc/profile.d/init.sh ; \
|
22 |
|
|
echo source $BZ2LIB_ROOT/etc/profile.d/init.sh ; \
|
23 |
|
|
echo source $DB4_ROOT/etc/profile.d/init.sh ; \
|
24 |
|
|
echo source $GDBM_ROOT/etc/profile.d/init.sh ; \
|
25 |
|
|
echo source $DB4_ROOT/etc/profile.d/init.sh ; ) > %i/etc/profile.d/dependencies-setup.sh
|
26 |
eulisse |
1.1 |
%install
|
27 |
|
|
cp -r * %i/
|
28 |
eulisse |
1.3 |
%post
|
29 |
|
|
perl -p -i -e "s!\@RPM_INSTALL_PREFIX\@!$RPM_INSTALL_PREFIX!" PRODREQUEST
|