1 |
eulisse |
1.75 |
### RPM cms prodrequest 0.6.0
|
2 |
eulisse |
1.76 |
## INITENV +PATH PYTHONPATH %i
|
3 |
eulisse |
1.1 |
%define moduleName PRODREQUEST
|
4 |
|
|
%define exportName PRODREQUEST
|
5 |
eulisse |
1.77 |
%define cvstag V00-06-02
|
6 |
eulisse |
1.1 |
%define cvsserver cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e
|
7 |
|
|
Source: %cvsserver&strategy=checkout&module=%{moduleName}&nocache=true&export=%{exportName}&tag=-r%{cvstag}&output=/PRODREQUEST.tar.gz
|
8 |
eulisse |
1.79 |
Requires: python py2-sqlobject py2-pysqlite cherrypy py2-cheetah yui sqlite py2-formencode zlib expat openssl bz2lib db4 gdbm prodcommon webtools dbs-client dls mysql py2-mysqldb py2-pycrypto
|
9 |
|
|
#Requires: prodagent boss
|
10 |
eulisse |
1.1 |
|
11 |
eulisse |
1.78 |
|
12 |
eulisse |
1.1 |
%prep
|
13 |
eulisse |
1.6 |
%setup -n PRODREQUEST
|
14 |
eulisse |
1.1 |
%build
|
15 |
eulisse |
1.7 |
rm -rf %i/etc/profile.d
|
16 |
|
|
mkdir -p %i/etc/profile.d/
|
17 |
eulisse |
1.8 |
dependenciesRoots="$PYTHON_ROOT $SQLITE_ROOT $PY2_SQLOBJECT_ROOT $PY2_PYSQLITE_ROOT $CHERRYPY_ROOT $YUI_ROOT \
|
18 |
eulisse |
1.67 |
$ZLIB_ROOT $EXPAT_ROOT $OPENSSL_ROOT $BZ2LIB_ROOT $DB4_ROOT $GDBM_ROOT $PY2_FORMENCODE_ROOT \
|
19 |
eulisse |
1.66 |
$PY2_CHEETAH_ROOT $PRODCOMMON_ROOT $WEBTOOLS_ROOT $DBS_CLIENT_ROOT $DLS_ROOT $BOSS_ROOT \
|
20 |
eulisse |
1.22 |
$PY2_MYSQLDB_ROOT $MYSQL_ROOT $PY2_PYCRYPTO_ROOT"
|
21 |
eulisse |
1.8 |
|
22 |
|
|
touch %i/etc/profile.d/dependencies-setup.sh
|
23 |
|
|
touch %i/etc/profile.d/dependencies-setup.csh
|
24 |
|
|
|
25 |
|
|
for pkg in $dependenciesRoots
|
26 |
|
|
do
|
27 |
|
|
echo $pkg
|
28 |
|
|
echo source $pkg/etc/profile.d/init.sh >> %i/etc/profile.d/dependencies-setup.sh
|
29 |
|
|
echo source $pkg/etc/profile.d/init.csh >> %i/etc/profile.d/dependencies-setup.csh
|
30 |
|
|
done
|
31 |
|
|
|
32 |
eulisse |
1.1 |
%install
|
33 |
|
|
cp -r * %i/
|
34 |
eulisse |
1.3 |
%post
|
35 |
eulisse |
1.8 |
%{relocateConfig}etc/profile.d/dependencies-setup.sh
|
36 |
|
|
%{relocateConfig}etc/profile.d/dependencies-setup.csh
|