1 |
steen |
1.1 |
### RPM external py-xmlrpc 0.8.8.2
|
2 |
|
|
%define pythonv %(echo $PYTHON_VERSION | cut -d. -f 1,2)
|
3 |
|
|
%define pydir %(which python| python -c "import sys,os; version=sys.version[:3];path='/'+reduce(lambda x,y: x+y+'/',sys.stdin.readline().split('/')[:-2]);print path")
|
4 |
|
|
%define bindir %pydir/bin
|
5 |
|
|
%define sitedir %pydir/lib/python%pythonv/site-packages
|
6 |
steen |
1.2 |
## INITENV +PATH PYTHONPATH %{i}/lib
|
7 |
steen |
1.1 |
|
8 |
|
|
Summary: xmlrpc for Python
|
9 |
|
|
Source0: http://switch.dl.sourceforge.net/sourceforge/py-xmlrpc/%n-%v.tar.gz
|
10 |
|
|
Patch0: py-xmlrpc-parse4
|
11 |
|
|
Patch1: py-xmlrpc-0.8.8.2-info
|
12 |
|
|
Group: Development/Libraries
|
13 |
|
|
Vendor: Shilad Sen <shilad.sen@sourcelight.com>
|
14 |
|
|
Url: http://sourceforge.net/projects/py-xmlrpc/
|
15 |
|
|
Requires: gcc python
|
16 |
|
|
|
17 |
|
|
%description
|
18 |
|
|
This kit contains an implementation of the xmlrpc protocol written in C and
|
19 |
|
|
wrapped up in python.
|
20 |
|
|
|
21 |
|
|
%setup
|
22 |
|
|
%patch0 -p0
|
23 |
|
|
%patch1 -p0
|
24 |
|
|
|
25 |
|
|
%build
|
26 |
|
|
export CFLAGS="-I%pydir/include/"
|
27 |
|
|
python setup.py build
|
28 |
|
|
|
29 |
|
|
%install
|
30 |
|
|
python setup.py install
|
31 |
|
|
mkdir -p %i/lib
|
32 |
|
|
mv %sitedir/_xmlrpc.so %i/lib
|
33 |
|
|
mv %sitedir/xmlrpc.* %i/lib
|
34 |
|
|
|
35 |
|
|
%files
|
36 |
|
|
%i
|