ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/py-xmlrpc.spec
Revision: 1.4
Committed: Thu May 11 23:03:52 2006 UTC (18 years, 11 months ago) by steen
Branch: MAIN
CVS Tags: phedex_2_3_series, V00-00-07, V00-00-06, V00-00-05, V00-00-04
Changes since 1.3: +3 -2 lines
Log Message:
Make sure patches are applied

Conrad Steenberg <conrad@hep.caltech.edu>
California Institute of Technology | http://conradsteenberg.info

File Contents

# User Rev Content
1 steen 1.1 ### RPM external py-xmlrpc 0.8.8.2
2     %define pythonv %(echo $PYTHON_VERSION | cut -d. -f 1,2)
3     %define pydir %(which python| python -c "import sys,os; version=sys.version[:3];path='/'+reduce(lambda x,y: x+y+'/',sys.stdin.readline().split('/')[:-2]);print path")
4     %define bindir %pydir/bin
5     %define sitedir %pydir/lib/python%pythonv/site-packages
6 steen 1.4 ## INITENV +PATH PYTHONPATH %{i}/lib/python%pythonv/site-packages
7 steen 1.1
8     Summary: xmlrpc for Python
9     Source0: http://switch.dl.sourceforge.net/sourceforge/py-xmlrpc/%n-%v.tar.gz
10     Patch0: py-xmlrpc-parse4
11     Patch1: py-xmlrpc-0.8.8.2-info
12     Group: Development/Libraries
13     Vendor: Shilad Sen <shilad.sen@sourcelight.com>
14     Url: http://sourceforge.net/projects/py-xmlrpc/
15     Requires: gcc python
16    
17     %description
18     This kit contains an implementation of the xmlrpc protocol written in C and
19     wrapped up in python.
20    
21 steen 1.4 %prep
22     %setup -n %n-%v
23 steen 1.1 %patch0 -p0
24     %patch1 -p0
25    
26     %build
27     export CFLAGS="-I%pydir/include/"
28     python setup.py build
29    
30     %install
31 steen 1.3 python setup.py install --prefix=%i