ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/py-xmlrpc.spec
Revision: 1.6
Committed: Wed Apr 18 23:46:02 2007 UTC (18 years ago) by ratnik
Branch: MAIN
CVS Tags: pe20070428a-ports, pe20070423b-ports, pe20070423a-ports
Changes since 1.5: +2 -0 lines
Log Message:
Changes for building  externals in 64/32 mode: added gcc-wrapper .

File Contents

# User Rev Content
1 steen 1.1 ### RPM external py-xmlrpc 0.8.8.2
2 ratnik 1.6 Requires: gcc-wrapper
3 steen 1.5 %define pythonv $(echo $PYTHON_VERSION | cut -d. -f 1,2)
4     %define pydir $(which python| python -c "import sys,os; version=sys.version[:3];path='/'+reduce(lambda x,y: x+y+'/',sys.stdin.readline().split('/')[:-2]);print path")
5 steen 1.1 %define bindir %pydir/bin
6     %define sitedir %pydir/lib/python%pythonv/site-packages
7 steen 1.4 ## INITENV +PATH PYTHONPATH %{i}/lib/python%pythonv/site-packages
8 steen 1.1
9     Summary: xmlrpc for Python
10     Source0: http://switch.dl.sourceforge.net/sourceforge/py-xmlrpc/%n-%v.tar.gz
11     Patch0: py-xmlrpc-parse4
12     Patch1: py-xmlrpc-0.8.8.2-info
13     Group: Development/Libraries
14     Vendor: Shilad Sen <shilad.sen@sourcelight.com>
15     Url: http://sourceforge.net/projects/py-xmlrpc/
16     Requires: gcc python
17    
18     %description
19     This kit contains an implementation of the xmlrpc protocol written in C and
20     wrapped up in python.
21    
22 steen 1.4 %prep
23     %setup -n %n-%v
24 steen 1.1 %patch0 -p0
25     %patch1 -p0
26    
27     %build
28 ratnik 1.6 ## IMPORT gcc-wrapper
29 steen 1.1 export CFLAGS="-I%pydir/include/"
30     python setup.py build
31    
32     %install
33 steen 1.3 python setup.py install --prefix=%i