ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/py2-cx-oracle.spec
Revision: 1.11
Committed: Mon May 23 15:59:45 2011 UTC (13 years, 11 months ago) by lat
Branch: MAIN
CVS Tags: TW20110627a, TW20110623b, TW20110623a, HG1106e, builder_2011-06-17_14-52-14_cmsweb, builder_2011-06-16_19-08-24_wmagent, builder_2011-06-16_16-09-02_wmagent, builder_2011-06-15_16-54-18_wmagent, builder_2011-06-10_23-58-54_cmsweb, HG1106d, builder_2011-06-07_22-07-15_reqmgr, builder_2011-05-31_01-23-03_cmsweb, builder_2011-05-31_00-51-28_cmsweb, HG1106c, TW20110530a, TW20110527b, TW20110527a, TW20110525a, TW20110524b, TW20110524a, builder_2011-05-24_10-10-21_cmsweb, HG1106b
Changes since 1.10: +0 -2 lines
Log Message:
Remove post-install changes to .py files as it prevents python from using
byte compile .pyc files. Update only strictly minimal set of files, which
are normally scripts in 'bin' directory - and which don't have .pyc files.

File Contents

# User Rev Content
1 valya 1.9 ### RPM external py2-cx-oracle 5.0.1
2 diego 1.10 ## INITENV +PATH PYTHONPATH %i/lib/python`echo $PYTHON_VERSION | cut -d. -f 1,2`/site-packages
3 lat 1.1 %define downloadn cx_Oracle
4 eulisse 1.5 Source: http://switch.dl.sourceforge.net/sourceforge/cx-oracle/%downloadn-%realversion.tar.gz
5 diego 1.10
6 metson 1.8 Requires: python oracle oracle-env
7 diego 1.10
8 lat 1.1 %prep
9 eulisse 1.5 %setup -n %downloadn-%realversion
10 lat 1.1
11 diego 1.10 cat >> setup.cfg <<- EOF
12     [build_ext]
13     include_dirs = $ORACLE_ROOT/include
14     library_dirs = $ORACLE_ROOT/lib
15     EOF
16    
17 lat 1.1 %build
18 diego 1.10 python setup.py build
19    
20 lat 1.1 %install
21     python setup.py install --prefix=%i
22 diego 1.10 find %i -name '*.egg-info' -exec rm {} \;