ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/py2-matplotlib.spec
Revision: 1.2
Committed: Sat Sep 16 09:55:42 2006 UTC (18 years, 7 months ago) by lat
Branch: MAIN
Changes since 1.1: +5 -3 lines
Log Message:
Fix PYTHONPATH setting.  Switch to numarray for now.

File Contents

# User Rev Content
1 lat 1.1 ### RPM external py2-matplotlib 0.87.4
2 lat 1.2 ## INITENV +PATH PYTHONPATH %i/lib/python$(echo $PYTHON_VERSION | cut -d. -f 1,2)/site-packages
3 lat 1.1 %define downloadn matplotlib
4     Source: http://switch.dl.sourceforge.net/sourceforge/%downloadn/%downloadn-%v.tar.gz
5     Requires: python
6 lat 1.2 # Requires: zlib
7 lat 1.1 # Requires: agg
8     # Requires: cairo
9 lat 1.2 Requires: py2-numarray
10 lat 1.1 Requires: libpng
11     # Requires: freetype
12     %prep
13     %setup -n %downloadn-%v
14 lat 1.2 pythonv=$(echo $PYTHON_VERSION | cut -d. -f 1,2)
15     perl -p -i -e "s,numarray_inc_dirs =.*,numarray_inc_dirs = ['$PY2_NUMARRAY_ROOT/include/python$pythonv']," setupext.py
16 lat 1.1
17     %build
18     %install
19     python setup.py install --prefix=%i
20     perl -p -i -e "s|^#!.*python(.*)|#!/usr/bin/env python$1|" `grep -r -e "#\!.*python" %i | cut -d: -f1`