1 |
elmer |
1.15 |
### RPM external py2-matplotlib 1.0.1
|
2 |
lat |
1.18 |
## INITENV +PATH PYTHONPATH %i/$PYTHON_LIB_SITE_PACKAGES
|
3 |
elmer |
1.15 |
Source: http://sourceforge.net/projects/matplotlib/files/matplotlib/matplotlib-%{realversion}/matplotlib-%{realversion}.tar.gz
|
4 |
lat |
1.22 |
Requires: py2-pytz py2-numpy py2-python-dateutil zlib libpng freetype
|
5 |
elmer |
1.15 |
|
6 |
lat |
1.1 |
%prep
|
7 |
elmer |
1.15 |
%setup -n matplotlib-%{realversion}
|
8 |
lat |
1.23 |
perl -p -i -e '/^import sys/ && print "for v in basedir.values(): v[:] = []\n"' setupext.py
|
9 |
eulisse |
1.16 |
|
10 |
diego |
1.14 |
cat >> setup.cfg <<- EOF
|
11 |
|
|
[build_ext]
|
12 |
lat |
1.23 |
include_dirs = $FREETYPE_ROOT/include/freetype2:$FREETYPE_ROOT/include:$LIBPNG_ROOT/include:$ZLIB_ROOT/include:/usr/X11R6/include:/usr/X11R6/include/freetype2
|
13 |
|
|
library_dirs = $FREETYPE_ROOT/lib:$LIBPNG_ROOT/lib:$ZLIB_ROOT/lib:/usr/X11/lib
|
14 |
lat |
1.22 |
|
15 |
|
|
[gui_support]
|
16 |
|
|
gtk = False
|
17 |
|
|
gtkagg = False
|
18 |
|
|
tkagg = False
|
19 |
|
|
wxagg = False
|
20 |
|
|
macosx = False
|
21 |
diego |
1.14 |
EOF
|
22 |
|
|
|
23 |
lat |
1.23 |
mkdir no-pkg-config
|
24 |
|
|
(echo '#!/bin/sh'; echo 'exit 1') > no-pkg-config/pkg-config
|
25 |
|
|
chmod +x no-pkg-config/pkg-config
|
26 |
lat |
1.22 |
|
27 |
lat |
1.1 |
%build
|
28 |
lat |
1.23 |
PATH=$PWD/no-pkg-config:$PATH \
|
29 |
elmer |
1.15 |
python setup.py build
|
30 |
diego |
1.14 |
|
31 |
lat |
1.1 |
%install
|
32 |
lat |
1.5 |
python -c 'import numpy'
|
33 |
lat |
1.23 |
PATH=$PWD/no-pkg-config:$PATH \
|
34 |
eulisse |
1.24 |
# Notice that the install procedure will try to write in $HOME/.matplotlib by
|
35 |
|
|
# default!!! This should work around the problem and have it write config
|
36 |
|
|
# in a scratch area.
|
37 |
|
|
export MPLCONFIGDIR=$PWD/no-pkg-config
|
38 |
|
|
|
39 |
lat |
1.1 |
python setup.py install --prefix=%i
|
40 |
diego |
1.14 |
find %i -name '*.egg-info' -exec rm {} \;
|
41 |
diego |
1.19 |
|
42 |
|
|
# No need for test files
|
43 |
|
|
rm -rf %i/$PYTHON_LIB_SITE_PACKAGES/matplotlib/tests
|