ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/py2-matplotlib.spec
Revision: 1.3
Committed: Sat Sep 16 13:00:06 2006 UTC (18 years, 7 months ago) by lat
Branch: MAIN
CVS Tags: pe060927
Changes since 1.2: +2 -0 lines
Log Message:
Finally working version with a (possibly bogus) patch added.

File Contents

# User Rev Content
1 lat 1.1 ### RPM external py2-matplotlib 0.87.4
2 lat 1.2 ## INITENV +PATH PYTHONPATH %i/lib/python$(echo $PYTHON_VERSION | cut -d. -f 1,2)/site-packages
3 lat 1.1 %define downloadn matplotlib
4     Source: http://switch.dl.sourceforge.net/sourceforge/%downloadn/%downloadn-%v.tar.gz
5 lat 1.3 Patch: py2-matplotlib.patch
6 lat 1.1 Requires: python
7 lat 1.2 # Requires: zlib
8 lat 1.1 # Requires: agg
9     # Requires: cairo
10 lat 1.2 Requires: py2-numarray
11 lat 1.1 Requires: libpng
12     # Requires: freetype
13     %prep
14     %setup -n %downloadn-%v
15 lat 1.3 %patch
16 lat 1.2 pythonv=$(echo $PYTHON_VERSION | cut -d. -f 1,2)
17     perl -p -i -e "s,numarray_inc_dirs =.*,numarray_inc_dirs = ['$PY2_NUMARRAY_ROOT/include/python$pythonv']," setupext.py
18 lat 1.1
19     %build
20     %install
21     python setup.py install --prefix=%i
22     perl -p -i -e "s|^#!.*python(.*)|#!/usr/bin/env python$1|" `grep -r -e "#\!.*python" %i | cut -d: -f1`