1 |
lat |
1.4 |
### RPM external py2-matplotlib 0.87.5
|
2 |
lat |
1.2 |
## INITENV +PATH PYTHONPATH %i/lib/python$(echo $PYTHON_VERSION | cut -d. -f 1,2)/site-packages
|
3 |
lat |
1.1 |
%define downloadn matplotlib
|
4 |
|
|
Source: http://switch.dl.sourceforge.net/sourceforge/%downloadn/%downloadn-%v.tar.gz
|
5 |
lat |
1.4 |
# Patch: py2-matplotlib.patch
|
6 |
lat |
1.1 |
Requires: python
|
7 |
lat |
1.2 |
# Requires: zlib
|
8 |
lat |
1.1 |
# Requires: agg
|
9 |
|
|
# Requires: cairo
|
10 |
lat |
1.4 |
# Requires: py2-numarray
|
11 |
|
|
Requires: py2-numpy
|
12 |
lat |
1.1 |
Requires: libpng
|
13 |
|
|
# Requires: freetype
|
14 |
|
|
%prep
|
15 |
|
|
%setup -n %downloadn-%v
|
16 |
lat |
1.4 |
# %patch
|
17 |
|
|
# pythonv=$(echo $PYTHON_VERSION | cut -d. -f 1,2)
|
18 |
|
|
# perl -p -i -e "s,numarray_inc_dirs =.*,numarray_inc_dirs = ['$PY2_NUMARRAY_ROOT/include/python$pythonv']," setupext.py
|
19 |
lat |
1.1 |
|
20 |
|
|
%build
|
21 |
|
|
%install
|
22 |
|
|
python setup.py install --prefix=%i
|
23 |
|
|
perl -p -i -e "s|^#!.*python(.*)|#!/usr/bin/env python$1|" `grep -r -e "#\!.*python" %i | cut -d: -f1`
|