1 |
eulisse |
1.6 |
### RPM external py2-matplotlib 0.87.7
|
2 |
ratnik |
1.8 |
Requires: gcc-wrapper
|
3 |
eulisse |
1.7 |
## INITENV +PATH PYTHONPATH %i/lib/python`echo $PYTHON_VERSION | cut -d. -f 1,2`/site-packages
|
4 |
lat |
1.1 |
%define downloadn matplotlib
|
5 |
|
|
Source: http://switch.dl.sourceforge.net/sourceforge/%downloadn/%downloadn-%v.tar.gz
|
6 |
|
|
Requires: python
|
7 |
lat |
1.2 |
# Requires: zlib
|
8 |
lat |
1.1 |
# Requires: agg
|
9 |
|
|
# Requires: cairo
|
10 |
eulisse |
1.6 |
Requires: py2-numpy
|
11 |
|
|
# py2-numpy is now built using its internal lapack_lite.
|
12 |
|
|
# uncomment if otherwise.
|
13 |
|
|
# Requires: atlas lapack
|
14 |
lat |
1.1 |
Requires: libpng
|
15 |
|
|
# Requires: freetype
|
16 |
|
|
%prep
|
17 |
|
|
%setup -n %downloadn-%v
|
18 |
|
|
|
19 |
|
|
%build
|
20 |
ratnik |
1.8 |
## IMPORT gcc-wrapper
|
21 |
lat |
1.1 |
%install
|
22 |
lat |
1.5 |
python -c 'import numpy'
|
23 |
lat |
1.1 |
python setup.py install --prefix=%i
|
24 |
|
|
perl -p -i -e "s|^#!.*python(.*)|#!/usr/bin/env python$1|" `grep -r -e "#\!.*python" %i | cut -d: -f1`
|