ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/py2-matplotlib.spec
Revision: 1.17
Committed: Mon May 23 15:59:45 2011 UTC (13 years, 11 months ago) by lat
Branch: MAIN
CVS Tags: TW20110627a, TW20110623b, TW20110623a, HG1106e, builder_2011-06-17_14-52-14_cmsweb, builder_2011-06-16_19-08-24_wmagent, builder_2011-06-16_16-09-02_wmagent, builder_2011-06-15_16-54-18_wmagent, builder_2011-06-10_23-58-54_cmsweb, HG1106d, builder_2011-06-07_22-07-15_reqmgr, builder_2011-05-31_01-23-03_cmsweb, builder_2011-05-31_00-51-28_cmsweb, HG1106c, TW20110530a, TW20110527b, TW20110527a, TW20110525a, TW20110524b, TW20110524a, builder_2011-05-24_10-10-21_cmsweb, HG1106b
Changes since 1.16: +0 -3 lines
Log Message:
Remove post-install changes to .py files as it prevents python from using
byte compile .pyc files. Update only strictly minimal set of files, which
are normally scripts in 'bin' directory - and which don't have .pyc files.

File Contents

# Content
1 ### RPM external py2-matplotlib 1.0.1
2 ## INITENV +PATH PYTHONPATH %i/lib/python`echo $PYTHON_VERSION | cut -d. -f 1,2`/site-packages
3 Source: http://sourceforge.net/projects/matplotlib/files/matplotlib/matplotlib-%{realversion}/matplotlib-%{realversion}.tar.gz
4
5 Requires: py2-numpy
6 Requires: zlib
7 Requires: libpng
8 %prep
9 %setup -n matplotlib-%{realversion}
10
11 cat >> setup.cfg <<- EOF
12 [build_ext]
13 include_dirs = $LIBPNG_ROOT/include:$ZLIB_ROOT/include:/usr/X11R6/include:/usr/X11R6/include/freetype2
14 library_dirs = $LIBPNG_ROOT/lib:$ZLIB_ROOT/lib:/usr/X11/lib
15 EOF
16
17 %build
18 python setup.py build
19
20 %install
21 python -c 'import numpy'
22 python setup.py install --prefix=%i
23 find %i -name '*.egg-info' -exec rm {} \;