ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/py2-numpy.spec
Revision: 1.14
Committed: Thu Feb 17 12:49:45 2011 UTC (14 years, 2 months ago) by eulisse
Branch: MAIN
Changes since 1.13: +8 -3 lines
Log Message:
Actually pick up our own version of lapack/blas.

File Contents

# User Rev Content
1 elmer 1.12 ### RPM external py2-numpy 1.5.1
2 eulisse 1.5 ## INITENV +PATH PYTHONPATH %i/lib/python`echo $PYTHON_VERSION | cut -d. -f 1,2`/site-packages
3 lat 1.1 %define downloadn numpy
4 eulisse 1.8 Source: http://switch.dl.sourceforge.net/sourceforge/%downloadn/%downloadn-%realversion.tar.gz
5 diego 1.11
6 elmer 1.12 Requires: python
7     Requires: zlib
8     Requires: lapack
9 lat 1.1 %prep
10 eulisse 1.8 %setup -n %downloadn-%realversion
11 diego 1.11
12 lat 1.1 %build
13     %install
14 eulisse 1.14 case %cmsos in
15     osx*) SONAME=dylib ;;
16     *) SONAME=so ;;
17     esac
18 elmer 1.12
19 eulisse 1.14 LAPACK=$LAPACK_ROOT/lib/liblapack.$SONAME
20     BLAS=$LAPACK_ROOT/lib/libblas.$SONAME
21    
22     LAPACK=$LAPACK BLAS=$BLAS python setup.py install --prefix=%i
23 diego 1.11 egrep -r -l '^#!.*python' %i | xargs perl -p -i -e 's{^#!.*python.*}{#!/usr/bin/env python}'
24     find %i -name '*.egg-info' -exec rm {} \;
25 elmer 1.12