ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/py2-numpy.spec
Revision: 1.15
Committed: Thu Feb 17 14:07:51 2011 UTC (14 years, 2 months ago) by eulisse
Branch: MAIN
Changes since 1.14: +6 -0 lines
Log Message:
Build on mac, without using the system Accelerate framework.

File Contents

# User Rev Content
1 elmer 1.12 ### RPM external py2-numpy 1.5.1
2 eulisse 1.5 ## INITENV +PATH PYTHONPATH %i/lib/python`echo $PYTHON_VERSION | cut -d. -f 1,2`/site-packages
3 lat 1.1 %define downloadn numpy
4 eulisse 1.8 Source: http://switch.dl.sourceforge.net/sourceforge/%downloadn/%downloadn-%realversion.tar.gz
5 eulisse 1.15 Patch0: py2-numpy-1.5.1-fix-macosx-build
6 diego 1.11
7 elmer 1.12 Requires: python
8     Requires: zlib
9     Requires: lapack
10 lat 1.1 %prep
11 eulisse 1.8 %setup -n %downloadn-%realversion
12 eulisse 1.15 case %cmsos in
13     osx*)
14     %patch0 -p1
15     ;;
16     esac
17 diego 1.11
18 lat 1.1 %build
19     %install
20 eulisse 1.14 case %cmsos in
21     osx*) SONAME=dylib ;;
22     *) SONAME=so ;;
23     esac
24 elmer 1.12
25 eulisse 1.14 LAPACK=$LAPACK_ROOT/lib/liblapack.$SONAME
26     BLAS=$LAPACK_ROOT/lib/libblas.$SONAME
27    
28     LAPACK=$LAPACK BLAS=$BLAS python setup.py install --prefix=%i
29 diego 1.11 egrep -r -l '^#!.*python' %i | xargs perl -p -i -e 's{^#!.*python.*}{#!/usr/bin/env python}'
30     find %i -name '*.egg-info' -exec rm {} \;
31 elmer 1.12