Revision: | 1.17 |
Committed: | Mon May 23 15:59:45 2011 UTC (13 years, 11 months ago) by lat |
Branch: | MAIN |
CVS Tags: | TW20110627a, TW20110623b, TW20110623a, HG1106e, builder_2011-06-17_14-52-14_cmsweb, builder_2011-06-16_19-08-24_wmagent, builder_2011-06-16_16-09-02_wmagent, builder_2011-06-15_16-54-18_wmagent, builder_2011-06-10_23-58-54_cmsweb, HG1106d, builder_2011-06-07_22-07-15_reqmgr, builder_2011-05-31_01-23-03_cmsweb, builder_2011-05-31_00-51-28_cmsweb, HG1106c, TW20110530a, TW20110527b, TW20110527a, TW20110525a, TW20110524b, TW20110524a, builder_2011-05-24_10-10-21_cmsweb, HG1106b |
Changes since 1.16: | +0 -2 lines |
Log Message: | Remove post-install changes to .py files as it prevents python from using byte compile .pyc files. Update only strictly minimal set of files, which are normally scripts in 'bin' directory - and which don't have .pyc files. |
# | User | Rev | Content |
---|---|---|---|
1 | elmer | 1.12 | ### RPM external py2-numpy 1.5.1 |
2 | eulisse | 1.5 | ## INITENV +PATH PYTHONPATH %i/lib/python`echo $PYTHON_VERSION | cut -d. -f 1,2`/site-packages |
3 | lat | 1.1 | %define downloadn numpy |
4 | eulisse | 1.8 | Source: http://switch.dl.sourceforge.net/sourceforge/%downloadn/%downloadn-%realversion.tar.gz |
5 | eulisse | 1.15 | Patch0: py2-numpy-1.5.1-fix-macosx-build |
6 | diego | 1.11 | |
7 | elmer | 1.12 | Requires: python |
8 | Requires: zlib | ||
9 | Requires: lapack | ||
10 | lat | 1.1 | %prep |
11 | eulisse | 1.8 | %setup -n %downloadn-%realversion |
12 | eulisse | 1.15 | case %cmsos in |
13 | osx*) | ||
14 | %patch0 -p1 | ||
15 | ;; | ||
16 | esac | ||
17 | diego | 1.11 | |
18 | lat | 1.1 | %build |
19 | %install | ||
20 | eulisse | 1.14 | case %cmsos in |
21 | osx*) SONAME=dylib ;; | ||
22 | *) SONAME=so ;; | ||
23 | esac | ||
24 | elmer | 1.12 | |
25 | eulisse | 1.14 | LAPACK=$LAPACK_ROOT/lib/liblapack.$SONAME |
26 | BLAS=$LAPACK_ROOT/lib/libblas.$SONAME | ||
27 | |||
28 | eulisse | 1.16 | LAPACK=$LAPACK BLAS=$BLAS python setup.py build --fcompiler "`which gfortran`" |
29 | eulisse | 1.14 | LAPACK=$LAPACK BLAS=$BLAS python setup.py install --prefix=%i |
30 | diego | 1.11 | find %i -name '*.egg-info' -exec rm {} \; |