ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/py2-numpy.spec
Revision: 1.2
Committed: Sat Sep 16 08:17:05 2006 UTC (18 years, 7 months ago) by lat
Branch: MAIN
CVS Tags: pe060927
Changes since 1.1: +9 -1 lines
Log Message:
Make sure PYTHONPATH is initialised correctly.  Create a site.cfg
to define where ATLAS libraries and directories are, and to
set which libraries should be used.  Not entirely sure just
what _should_ be used, but pick what seems reasonable.

File Contents

# User Rev Content
1 lat 1.1 ### RPM external py2-numpy 1.0b5
2 lat 1.2 ## INITENV +PATH PYTHONPATH %i/lib/python$(echo $PYTHON_VERSION | cut -d. -f 1,2)/site-packages
3 lat 1.1 %define downloadn numpy
4     Source: http://switch.dl.sourceforge.net/sourceforge/%downloadn/%downloadn-%v.tar.gz
5     Requires: python
6     Requires: zlib
7     Requires: atlas
8     %prep
9     %setup -n %downloadn-%v
10    
11 lat 1.2 cat > site.cfg <<EOF
12     [atlas]
13     include_dirs = $ATLAS_ROOT/include
14     library_dirs = $ATLAS_ROOT/lib
15     atlas_libs = ptf77blas, ptcblas
16     lapack_libs = lapack_atlas
17     EOF
18    
19 lat 1.1 %build
20     %install
21     python setup.py install --prefix=%i
22     perl -p -i -e "s|^#!.*python(.*)|#!/usr/bin/env python$1|" `grep -r -e "#\!.*python" %i | cut -d: -f1`