ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/py2-numpy.spec
Revision: 1.4
Committed: Wed Jan 24 21:44:00 2007 UTC (18 years, 3 months ago) by eulisse
Branch: MAIN
Changes since 1.3: +6 -11 lines
Log Message:
Builds numpy without external atlas/lapack/blas libraries but relying only
on the internal "lite" version.

File Contents

# User Rev Content
1 eulisse 1.4 ### RPM external py2-numpy 1.0.1
2 lat 1.2 ## INITENV +PATH PYTHONPATH %i/lib/python$(echo $PYTHON_VERSION | cut -d. -f 1,2)/site-packages
3 lat 1.1 %define downloadn numpy
4     Source: http://switch.dl.sourceforge.net/sourceforge/%downloadn/%downloadn-%v.tar.gz
5 eulisse 1.4 Patch0: py2-numpy-build
6 lat 1.1 Requires: python
7     Requires: zlib
8     %prep
9     %setup -n %downloadn-%v
10 eulisse 1.4 %patch0 -p0
11 lat 1.1 %build
12     %install
13 eulisse 1.4 export LAPACK_SRC=%_builddir/%downloadn-%v/LAPACK
14     export BLAS_SRC=%_builddir/%downloadn-%v/BLAS
15     env
16 lat 1.1 python setup.py install --prefix=%i
17     perl -p -i -e "s|^#!.*python(.*)|#!/usr/bin/env python$1|" `grep -r -e "#\!.*python" %i | cut -d: -f1`