ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/py2-pil.spec
Revision: 1.1
Committed: Mon Jan 29 18:40:58 2007 UTC (18 years, 3 months ago) by eulisse
Branch: MAIN
Log Message:
First added to repository.

File Contents

# User Rev Content
1 eulisse 1.1 ### RPM external py2-pil 1.1.6
2     ## INITENV +PATH PYTHONPATH %i/lib/python$(echo $PYTHON_VERSION | cut -d. -f 1,2)/site-packages
3     %define downloadn Imaging
4     Source: http://effbot.org/downloads/%downloadn-%v.tar.gz
5     Requires: python
6     # Requires: zlib
7     # Requires: agg
8     # Requires: cairo
9     # py2-numpy is now built using its internal lapack_lite.
10     # uncomment if otherwise.
11     # Requires: atlas lapack
12     Requires: libpng libjpg zlib
13     # Requires: freetype
14     %prep
15     %setup -n %downloadn-%v
16     perl -p -i -e "s!__PREFIX__!%i!" setup.py
17    
18     %build
19     %install
20     python setup.py install
21     perl -p -i -e "s|^#!.*python(.*)|#!/usr/bin/env python$1|" `grep -r -e "#\!.*python" %i | cut -d: -f1`