ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/py2-pil.spec
Revision: 1.3
Committed: Wed Jan 31 14:57:56 2007 UTC (18 years, 2 months ago) by eulisse
Branch: MAIN
Changes since 1.2: +1 -0 lines
Log Message:
relocated shebang for python.

File Contents

# User Rev Content
1 eulisse 1.1 ### RPM external py2-pil 1.1.6
2     ## INITENV +PATH PYTHONPATH %i/lib/python$(echo $PYTHON_VERSION | cut -d. -f 1,2)/site-packages
3     %define downloadn Imaging
4     Source: http://effbot.org/downloads/%downloadn-%v.tar.gz
5     Requires: python
6     # Requires: zlib
7     # Requires: agg
8     # Requires: cairo
9     # py2-numpy is now built using its internal lapack_lite.
10     # uncomment if otherwise.
11     # Requires: atlas lapack
12 eulisse 1.2 Requires: libpng libjpg zlib libtiff
13 eulisse 1.1 # Requires: freetype
14     %prep
15     %setup -n %downloadn-%v
16     perl -p -i -e "s!__PREFIX__!%i!" setup.py
17 eulisse 1.2 perl -p -i -e "s!JPEG_ROOT = None!JPEG_ROOT =\"$LIBJPG_ROOT\" !" setup.py
18     perl -p -i -e "s!TIFF_ROOT = None!TIFF_ROOT =\"$LIBTIFF_ROOT\" !" setup.py
19     perl -p -i -e "s!ZLIB_ROOT = None!ZLIB_ROOT =\"$ZLIB_ROOT\" !" setup.py
20 eulisse 1.1 %build
21 eulisse 1.2 python setup.py build_ext -i
22     python selftest.py
23 eulisse 1.1 %install
24 eulisse 1.2 python setup.py install --prefix=%i
25 eulisse 1.3 perl -p -i -e "s|^#!.*python(.*)|#!/usr/bin/env python$1|" `grep -r -e "^#\!.*python.*" %i | cut -d: -f1`