ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/py2-pil.spec
Revision: 1.5
Committed: Wed Apr 18 23:46:02 2007 UTC (18 years ago) by ratnik
Branch: MAIN
Changes since 1.4: +2 -0 lines
Log Message:
Changes for building  externals in 64/32 mode: added gcc-wrapper .

File Contents

# User Rev Content
1 eulisse 1.1 ### RPM external py2-pil 1.1.6
2 ratnik 1.5 Requires: gcc-wrapper
3 eulisse 1.4 ## INITENV +PATH PYTHONPATH %i/lib/python`echo $PYTHON_VERSION | cut -d. -f 1,2`/site-packages
4 eulisse 1.1 %define downloadn Imaging
5     Source: http://effbot.org/downloads/%downloadn-%v.tar.gz
6     Requires: python
7     # Requires: zlib
8     # Requires: agg
9     # Requires: cairo
10     # py2-numpy is now built using its internal lapack_lite.
11     # uncomment if otherwise.
12     # Requires: atlas lapack
13 eulisse 1.2 Requires: libpng libjpg zlib libtiff
14 eulisse 1.1 # Requires: freetype
15     %prep
16     %setup -n %downloadn-%v
17     perl -p -i -e "s!__PREFIX__!%i!" setup.py
18 eulisse 1.2 perl -p -i -e "s!JPEG_ROOT = None!JPEG_ROOT =\"$LIBJPG_ROOT\" !" setup.py
19     perl -p -i -e "s!TIFF_ROOT = None!TIFF_ROOT =\"$LIBTIFF_ROOT\" !" setup.py
20     perl -p -i -e "s!ZLIB_ROOT = None!ZLIB_ROOT =\"$ZLIB_ROOT\" !" setup.py
21 eulisse 1.1 %build
22 ratnik 1.5 ## IMPORT gcc-wrapper
23 eulisse 1.2 python setup.py build_ext -i
24     python selftest.py
25 eulisse 1.1 %install
26 eulisse 1.2 python setup.py install --prefix=%i
27 eulisse 1.3 perl -p -i -e "s|^#!.*python(.*)|#!/usr/bin/env python$1|" `grep -r -e "^#\!.*python.*" %i | cut -d: -f1`