ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/py2-pyopenssl.spec
Revision: 1.5
Committed: Thu Apr 24 19:34:07 2008 UTC (17 years ago) by afanfani
Branch: MAIN
CVS Tags: SiteDB_030608_1, SiteDB_300508_1, SiteDB_280508_1, zx20080509, pe20080508-testcvs, dl080505, dl080425_for21x
Changes since 1.4: +1 -1 lines
Log Message:
fix the usual error in python version definition

File Contents

# User Rev Content
1 steen 1.1 ### RPM external py2-pyopenssl 0.6.900
2 afanfani 1.5 %define pythonv `echo $PYTHON_VERSION | cut -d. -f 1,2`
3 steen 1.1 ## INITENV +PATH PYTHONPATH %{i}/lib/python%{pythonv}/site-packages
4     ## INITENV +PATH PATH %{i}/bin
5    
6     Summary: A Python wrapper for OpenSSL
7     Group: Development/Libraries
8     Packager: Conrad Steenberg <conrad@hep.caltech.edu>
9     Source: http://julian.ultralight.org/clarens/devel/pyOpenSSL-%v.tar.gz
10 steen 1.2 Requires: python openssl
11 steen 1.1 %prep
12     %setup -n pyOpenSSL-%{v}
13    
14     %build
15     CFLAGS="-I$OPENSSL_ROOT/include -I$OPENSSL_ROOT/include/openssl" LDFLAGS="-L$OPENSSL_ROOT/lib" \
16     python setup.py build
17    
18     %install
19     python setup.py install --prefix=%i