ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/py2-scipy.spec
Revision: 1.2
Committed: Wed Apr 18 23:46:02 2007 UTC (18 years ago) by ratnik
Branch: MAIN
Changes since 1.1: +2 -0 lines
Log Message:
Changes for building  externals in 64/32 mode: added gcc-wrapper .

File Contents

# User Rev Content
1 lat 1.1 ### RPM external py2-scipy 0.5.1
2 ratnik 1.2 Requires: gcc-wrapper
3 lat 1.1 ## INITENV +PATH PYTHONPATH %i/lib/python$(echo $PYTHON_VERSION | cut -d. -f 1,2)/site-packages
4     %define downloadn scipy
5     Source: http://switch.dl.sourceforge.net/sourceforge/%downloadn/%downloadn-%v.tar.gz
6     Requires: python
7     Requires: py2-numpy
8     Requires: atlas
9     %prep
10     %setup -n %downloadn-%v
11    
12     cat > site.cfg <<EOF
13     [atlas]
14     include_dirs = $ATLAS_ROOT/include
15     library_dirs = $ATLAS_ROOT/lib
16     atlas_libs = ptf77blas, ptcblas
17     lapack_libs = lapack_atlas
18     EOF
19    
20     %build
21 ratnik 1.2 ## IMPORT gcc-wrapper
22 lat 1.1 %install
23     python setup.py install --prefix=%i
24     perl -p -i -e "s|^#!.*python(.*)|#!/usr/bin/env python$1|" `grep -r -e "#\!.*python" %i | cut -d: -f1`