ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/pyOpenSSL.spec
Revision: 1.2
Committed: Wed Apr 18 23:46:02 2007 UTC (18 years ago) by ratnik
Branch: MAIN
CVS Tags: pe20070428a-ports, pe20070423b-ports, pe20070423a-ports
Changes since 1.1: +2 -0 lines
Log Message:
Changes for building  externals in 64/32 mode: added gcc-wrapper .

File Contents

# User Rev Content
1 steen 1.1 ### RPM external pyOpenSSL 0.6.900
2 ratnik 1.2 Requires: gcc-wrapper
3 steen 1.1 %define pythonv %(echo $PYTHON_VERSION | cut -d. -f 1,2)
4     ## INITENV +PATH PYTHONPATH %{i}/lib/python%{pythonv}/site-packages
5     ## INITENV +PATH PATH %{i}/bin
6    
7     Summary: A Python wrapper for OpenSSL
8     Group: Development/Libraries
9     Packager: Conrad Steenberg <conrad@hep.caltech.edu>
10     Source: http://julian.ultralight.org/clarens/devel/%n-%v.tar.gz
11     Requires: python
12     %prep
13     %setup -n %n-%{v}
14    
15     %build
16 ratnik 1.2 ## IMPORT gcc-wrapper
17 steen 1.1 CFLAGS="-I$OPENSSL_ROOT/include -I$OPENSSL_ROOT/include/openssl" LDFLAGS="-L$OPENSSL_ROOT/lib" \
18     python setup.py build
19    
20     %install
21     python setup.py install --prefix=%i