ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/pyqt.spec
Revision: 1.13
Committed: Fri Sep 24 07:45:13 2010 UTC (14 years, 7 months ago) by elmer
Branch: MAIN
CVS Tags: pe20101011b-for39Xrb, pe20101011a-for39Xrb, pe20101008c-for39Xrb, pe20101008b-for39Xrb, pe20101008a-for39Xrb, pe20101005a-for39Xrb, pe20101004a-for39Xrb, pe20101001b-for39Xrb, pe20101001a-for39Xrb, pe20100930c-for39Xrb, pe20100930b-for39Xrb, pe20100930a-for39Xrb, pe20100925a-for39Xrb, pe20100924b-for39Xrb, pe20100924a-for39Xrb
Changes since 1.12: +1 -1 lines
Log Message:
Update to version 4.7.7, with minor changes. Version 4.7.6 appears to have
disappeared off their servers and it isn't worth forcing it to use 4.7.6 as
we hadn't yet done an official build of it anyway.

File Contents

# User Rev Content
1 elmer 1.13 ### RPM external pyqt 4.7.7
2 elmer 1.6 ## INITENV +PATH PYTHONPATH %i/lib/python`echo $PYTHON_VERSION | cut -d. -f 1,2`/site-packages
3 eulisse 1.1 ## BUILDIF case %cmsplatf in osx*) false;; *) true;; esac
4     Source: http://www.riverbankcomputing.co.uk/static/Downloads/PyQt4/PyQt-x11-gpl-%realversion.tar.gz
5 eulisse 1.8 Patch0: pyqt-relocatable-build
6 eulisse 1.1 Requires: python
7     Requires: qt
8     Requires: sip
9    
10     %prep
11     %setup -n PyQt-x11-gpl-%realversion
12 eulisse 1.7 # pyqt builds and uses an helper program "qtdirs" to determine where qt is installed.
13     # We had to patch its sources so that it reads the configuration file qt.conf
14     # like other qt applications, so that we get the correctly relocated information.
15 elmer 1.9 # Notice that in the build section we copy qt.conf from the QT installation to
16     # get the correct location.
17 eulisse 1.7 %patch0 -p1
18 eulisse 1.1
19     %build
20 eulisse 1.7 # See above for explanation.
21     cp $QT_ROOT/bin/qt.conf .
22    
23 elmer 1.6 echo yes | python ./configure.py --verbose -b %i/bin -d %i/lib/python`echo $PYTHON_VERSION | cut -d. -f 1,2`/site-packages \
24 eulisse 1.4 -e %i/include \
25     `find $QT_ROOT/include/ -type d | xargs -n 1 basename| grep -v include | xargs echo | sed -e 's| | --enable=|g;s|^|--enable=|'`
26    
27 eulisse 1.1 make %makeprocesses
28    
29     %install
30     make install
31    
32 eulisse 1.4 mkdir -p %i/etc/profile.d
33     cat << \EOF_INIT_ME > %i/etc/profile.d/init-standalone.sh
34     #!/bin/sh
35     source @GCC_ROOT@/etc/profile.d/init.sh
36     source @BZ2LIB_ROOT@/etc/profile.d/init.sh
37     source @EXPAT_ROOT@/etc/profile.d/init.sh
38     source @DB4_ROOT@/etc/profile.d/init.sh
39     source @GDBM_ROOT@/etc/profile.d/init.sh
40     source @ZLIB_ROOT@/etc/profile.d/init.sh
41     source @OPENSSL_ROOT@/etc/profile.d/init.sh
42     source @PYTHON_ROOT@/etc/profile.d/init.sh
43     source @QT_ROOT@/etc/profile.d/init.sh
44     source @SIP_ROOT@/etc/profile.d/init.sh
45     source %i/etc/profile.d/init.sh
46     EOF_INIT_ME
47    
48     perl -p -i -e "s|\@([^@]*)\@|\$ENV{\$1}|" %i/etc/profile.d/init-standalone.sh
49 eulisse 1.1
50 eulisse 1.2 %post
51 eulisse 1.4 %{relocateConfig}etc/profile.d/init-standalone.sh